Bug 1019748 - CLI - 'system packages --install "fakepackage" --environment "Library"' runs endless
CLI - 'system packages --install "fakepackage" --environment "Library"' runs ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: katello-agent (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity low (vote)
: Unspecified
: --
Assigned To: Justin Sherrill
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-16 06:53 EDT by Hayk Hovsepyan
Modified: 2016-08-25 13:12 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-25 13:12:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hayk Hovsepyan 2013-10-16 06:53:13 EDT
Description of problem:
When trying to remote install some package (in this scenario fake package) on system registered to "Library" environment it runs endless.

Version-Release number of selected component (if applicable):
Katello-Katello-Installation-RegisterRHNClassic-1.1-4.noarch
python-ldap-2.3.10-1.el6.x86_64
pulp-selinux-2.3.0-0.16.alpha.el6.noarch
pulp-rpm-plugins-2.3.0-0.16.alpha.el6.noarch
candlepin-selinux-0.8.29-1.el6.noarch
katello-common-1.5.1-1.git.12.0793e55.el6.noarch
apr-util-ldap-1.3.9-3.el6_0.1.x86_64
openldap-2.4.23-31.el6.x86_64
katello-all-1.5.1-1.git.12.0793e55.el6.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
ruby193-rubygem-ldap_fluff-0.2.2-2.el6.noarch
signo-0.0.22-1.el6.noarch
katello-cli-common-1.5.1-1.git.2.10cf659.el6.noarch
Katello-Katello-Installation-ConfigureRepos-1.7-5.noarch
katello-repos-1.5.1-1.el6.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-qpid-client-key-pair-1.0-1.noarch
pulp-rpm-handlers-2.3.0-0.16.alpha.el6.noarch
katello-agent-1.5.1-1.el6.noarch
candlepin-cert-consumer-apollo.usersys.redhat.com-1.0-1.noarch
ruby193-rubygem-net-ldap-0.3.1-1.el6.noarch
katello-configure-1.5.1-1.git.4.2d2c298.el6.noarch
pulp-server-2.3.0-0.16.alpha.el6.noarch
pulp-katello-plugins-0.2-1.el6.noarch
pulp-nodes-parent-2.3.0-0.16.alpha.el6.noarch
candlepin-0.8.29-1.el6.noarch
signo-katello-0.0.22-1.el6.noarch
katello-glue-elasticsearch-1.5.1-1.git.12.0793e55.el6.noarch
katello-glue-candlepin-1.5.1-1.git.12.0793e55.el6.noarch
candlepin-tomcat6-0.8.29-1.el6.noarch
pulp-puppet-plugins-2.3.0-0.16.alpha.el6.noarch
katello-1.5.1-1.git.12.0793e55.el6.noarch
katello-cli-1.5.1-1.git.2.10cf659.el6.noarch
Katello-Katello-Installation-KatelloNightly-1.0-13.noarch
katello-certs-tools-1.5.1-1.el6.noarch
pulp-nodes-common-2.3.0-0.16.alpha.el6.noarch
elasticsearch-0.19.9-7.el6.noarch
katello-selinux-1.5.1-1.el6.noarch
katello-glue-pulp-1.5.1-1.git.12.0793e55.el6.noarch
Katello-Katello-Configuration-KatelloClient-1.1-53.noarch
Katello-Katello-Sanity-ImportKeys-1.2-1.noarch

How reproducible:
always

Steps to Reproduce:
1. create an org
2. register system to "Library" of that org
3. remote install some package (fake of from zoo repo) on that system 'system packages --install "fakepackage" --org "$orgname" --name "$systemname" --environment "Library"'. It will run endless.

Actual results:
install process runs endless

Expected results:
should finish with appropriate message that no package is installed

Additional info:
on other environments it works ok
Comment 1 RHEL Product and Program Management 2013-10-16 06:55:46 EDT
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 3 Hayk Hovsepyan 2013-10-17 07:39:10 EDT
Katello Nightly only.

The same problem when adding the system (in Libraary) to system_group and trying to install any package on system group remotely.
Comment 6 Justin Sherrill 2016-08-25 13:12:15 EDT
On Satellite 6.2 this does not seem to be the case:

[vagrant@robot hammer-cli-katello]$ hammer -u admin -p changeme host package install --host-id=2 --packages=asdfasdfsf
[...............................................................................................................................................] [100%]
*:asdfasdfsf-*-*.*: No package(s) available to install

Note You need to log in before you can comment on or make changes to this bug.