Bug 1019773 - UI should truncate the long system name
UI should truncate the long system name
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.2
Unspecified Unspecified
medium Severity medium (vote)
: Unspecified
: --
Assigned To: Christine Fouant
sthirugn@redhat.com
http://projects.theforeman.org/issues...
: Triaged
: 1097060 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-16 07:32 EDT by Sachin Ghai
Modified: 2016-04-22 12:52 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-11 08:23:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
long system name overlaps other fields (86.80 KB, image/png)
2013-10-16 07:32 EDT, Sachin Ghai
no flags Details
content host name now wrapped (84.06 KB, image/png)
2014-07-25 16:03 EDT, sthirugn@redhat.com
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 6262 None None None 2016-04-22 12:52 EDT

  None (edit)
Description Sachin Ghai 2013-10-16 07:32:52 EDT
Created attachment 812871 [details]
long system name overlaps other fields

Description of problem:
Created a system name of 255 characters. It was created successfully, however while displaying under system list, the name is overlapping other fields.

Version-Release number of selected component (if applicable):
snap5 compose2 (MDP2)
katello-1.4.6-31.el6sat.noarch

How reproducible:
always

Steps to Reproduce:
1. create a system of long length
2. go to systems -->All
3.

Actual results:
long system name overlaps other fields

Expected results:
UI should truncate system name.

Additional info:
Comment 2 Christine Fouant 2014-06-17 17:30:45 EDT
Created redmine issue http://projects.theforeman.org/issues/6262 from this bug
Comment 3 Bryan Kearney 2014-06-18 18:01:33 EDT
Moving to POST since upstream bug http://projects.theforeman.org/issues/6262 has been closed
Comment 4 Walden Raines 2014-06-25 10:18:38 EDT
*** Bug 1097060 has been marked as a duplicate of this bug. ***
Comment 6 sthirugn@redhat.com 2014-07-25 16:03:05 EDT
Verified. (see screenshot)

Version Tested:
* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.9.19-1.el6_5.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.9.19-1.el6_5.noarch
* candlepin-tomcat6-0.9.19-1.el6_5.noarch
* elasticsearch-0.90.10-4.el6sat.noarch
* foreman-1.6.0.29-1.el6sat.noarch
* foreman-compute-1.6.0.29-1.el6sat.noarch
* foreman-gce-1.6.0.29-1.el6sat.noarch
* foreman-libvirt-1.6.0.29-1.el6sat.noarch
* foreman-ovirt-1.6.0.29-1.el6sat.noarch
* foreman-postgresql-1.6.0.29-1.el6sat.noarch
* foreman-proxy-1.6.0.21-1.el6sat.noarch
* foreman-selinux-1.6.0-8.el6sat.noarch
* foreman-vmware-1.6.0.29-1.el6sat.noarch
* katello-1.5.0-27.el6sat.noarch
* katello-ca-1.0-1.noarch
* katello-certs-tools-1.5.6-1.el6sat.noarch
* katello-installer-0.0.56-1.el6sat.noarch
* openldap-2.4.23-32.el6_4.1.x86_64
* pulp-katello-0.3-3.el6sat.noarch
* pulp-nodes-common-2.4.0-0.23.beta.el6sat.noarch
* pulp-nodes-parent-2.4.0-0.23.beta.el6sat.noarch
* pulp-puppet-plugins-2.4.0-0.23.beta.el6sat.noarch
* pulp-puppet-tools-2.4.0-0.23.beta.el6sat.noarch
* pulp-rpm-plugins-2.4.0-0.23.beta.el6sat.noarch
* pulp-selinux-2.4.0-0.23.beta.el6sat.noarch
* pulp-server-2.4.0-0.23.beta.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.1.0-2.el6sat.noarch
Comment 7 sthirugn@redhat.com 2014-07-25 16:03:34 EDT
Created attachment 921048 [details]
content host name now wrapped
Comment 9 Bryan Kearney 2014-09-11 08:23:18 EDT
This was delivered with Satellite 6.0 which was released on 10 September 2014.

Note You need to log in before you can comment on or make changes to this bug.