Bug 101978 - bug in russian translation gettext file mailman.po or in gettext
bug in russian translation gettext file mailman.po or in gettext
Status: CLOSED DUPLICATE of bug 101977
Product: Red Hat Linux
Classification: Retired
Component: mailman (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Dennis
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-08 11:01 EDT by Victor Ashik
Modified: 2007-04-18 12:56 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:58:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Victor Ashik 2003-08-08 11:01:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
In file /var/mailman/messages/ru/LC_MESSAGES/mailman.po
there is a translation for file admin.py:263 (line 333):

#: Mailman/Cgi/admin.py:263
msgid ""
"To visit the administrators configuration page for an\n"
"        unadvertised list, open a URL similar to this one, but with a '/' "
"and\n"
"        the %(extra)slist name appended.  If you have the proper authority,\n"
"        you can also <a href=\'%(creatorurl)s\'>create a new mailing list</"
"a>.\n"
"\n"
"        <p>General list information can be found at "
msgstr ""
"&#1044;&#1083;&#1103; &#1090;&#1086;&#1075;&#1086;,
&#1095;&#1090;&#1086;&#1073;&#1099;
&#1087;&#1086;&#1089;&#1077;&#1090;&#1080;&#1090;&#1100;
&#1089;&#1090;&#1088;&#1072;&#1085;&#1080;&#1094;&#1091;
&#1085;&#1072;&#1089;&#1090;&#1088;&#1086;&#1081;&#1082;&#1080;
&#1089;&#1087;&#1080;&#1089;&#1082;&#1072;
&#1088;&#1072;&#1089;&#1089;&#1099;&#1083;&#1082;&#1080;, &#1085;&#1077;
&#1091;&#1082;&#1072;&#1079;&#1072;&#1085;&#1085;&#1086;&#1075;&#1086;\n"
"       &#1079;&#1076;&#1077;&#1089;&#1100;,
&#1076;&#1086;&#1073;&#1072;&#1074;&#1100;&#1090;&#1077; &#1082;
&#1072;&#1076;&#1088;&#1077;&#1089;&#1091; &#1101;&#1090;&#1086;&#1081;
&#1089;&#1090;&#1088;&#1072;&#1085;&#1080;&#1094;&#1099;
&#1089;&#1080;&#1084;&#1074;&#1086;&#1083; '/', &#1079;&#1072;
&#1082;&#1086;&#1090;&#1086;&#1088;&#1099;&#1084;\n"
"       &#1074;&#1099; &#1076;&#1086;&#1083;&#1078;&#1085;&#1099;
&#1091;&#1082;&#1072;&#1079;&#1072;&#1090;&#1100; %(extra)s&#1080;&#1084;&#1103;
&#1089;&#1087;&#1080;&#1089;&#1082;&#1072;
&#1088;&#1072;&#1089;&#1089;&#1099;&#1083;&#1082;&#1080;.
&#1045;&#1089;&#1083;&#1080; &#1091; &#1074;&#1072;&#1089;
&#1077;&#1089;&#1090;&#1100; &#1087;&#1088;&#1072;&#1074;&#1086; "
"&#1089;&#1086;&#1079;&#1076;&#1072;&#1074;&#1072;&#1090;&#1100;\n"
"       &#1089;&#1087;&#1080;&#1089;&#1082;&#1080;
&#1088;&#1072;&#1089;&#1089;&#1099;&#1083;&#1082;&#1080; &#1085;&#1072;
&#1101;&#1090;&#1086;&#1084; &#1089;&#1077;&#1088;&#1074;&#1077;&#1088;&#1077;,
&#1074;&#1099; &#1084;&#1086;&#1078;&#1077;&#1090;&#1077;
&#1087;&#1077;&#1088;&#1077;&#1081;&#1090;&#1080; &#1082; <a href=\'%s"
"(creatorurl)s\'>&#1089;&#1090;&#1088;&#1072;&#1085;&#1080;&#1094;&#1077;
&#1089;&#1086;&#1079;&#1076;&#1072;&#1085;&#1080;&#1103;
&#1089;&#1087;&#1080;&#1089;&#1082;&#1086;&#1074;
&#1088;&#1072;&#1089;&#1089;&#1099;&#1083;&#1086;&#1082;</a>.\n"

Possibly, there is a bug in gettext in working with '"' in russian causing error
on page http://localhost/mailman/admin when 
DEFAULT_SERVER_LANGUAGE = 'ru' in /var/mailman/Mailman/mm_cfg.py

Version-Release number of selected component (if applicable):
2.1-8

How reproducible:
Always

Steps to Reproduce:
1.Install mailman and httpd packages
2.Add DEFAULT_SERVER_LANGUAGE = 'ru' to the file /var/mailman/Mailman/mm_cfg.py
3.service mailman start
4. Open http://localhost/mailman/admin in browser
    

Actual Results:  Error message from Python:

Bug in Mailman version 2.1

We're sorry, we hit a bug!

If you would like to help us identify the problem, please email a copy of this
page to the webmaster for this site with a description of what happened. Thanks!
Traceback:

Traceback (most recent call last):
  File "/var/mailman/scripts/driver", line 87, in run_main
    main()
  File "/var/mailman/Mailman/Cgi/admin.py", line 61, in main
    admin_overview()
  File "/var/mailman/Mailman/Cgi/admin.py", line 262, in admin_overview
    welcome.extend([
  File "/var/mailman/Mailman/i18n.py", line 78, in _
    return _translation.gettext(s) % dict
TypeError: not enough arguments for format string



Python information:

Variable Value
sys.version 2.2.2 (#1, Feb 24 2003, 19:13:11) [GCC 3.2.2 20030222 (Red Hat Linux
3.2.2-4)]
sys.executable /usr/bin/python
sys.prefix /usr
sys.exec_prefix /usr
sys.path /usr
sys.platform linux2

Environment variables:

Variable Value
PYTHONPATH /var/mailman
SCRIPT_FILENAME /var/mailman/cgi-bin/admin
SERVER_SOFTWARE Apache/2.0.40 (Red Hat Linux)
SERVER_ADMIN nobody@nowhere.ru
SCRIPT_NAME /mailman/admin
SERVER_SIGNATURE
Apache/2.0.40 Server at localhost Port 80
REQUEST_METHOD GET
HTTP_HOST localhost
HTTP_KEEP_ALIVE 300
SERVER_PROTOCOL HTTP/1.1
QUERY_STRING
REQUEST_URI /mailman/admin
HTTP_ACCEPT
text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,video/x-mng,image/png,image/jpeg,image/gif;q=0.2,text/css,*/*;q=0.1
HTTP_ACCEPT_CHARSET ISO-8859-1, utf-8;q=0.66, *;q=0.66
HTTP_USER_AGENT Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131
HTTP_CONNECTION keep-alive
SERVER_NAME localhost
REMOTE_PORT 59406
REMOTE_ADDR 127.0.0.1
HTTP_ACCEPT_LANGUAGE ru, en;q=0.50
UNIQUE_ID KrLi@38AAAEAABN4DlUAAAAC
SERVER_PORT 80
GATEWAY_INTERFACE CGI/1.1
HTTP_ACCEPT_ENCODING gzip, deflate, compress;q=0.9
SERVER_ADDR 127.0.0.1
DOCUMENT_ROOT /var/www/html

Expected Results:  Web page with localized administration interface:



Additional info:

Double quotes can be changed to single for workaround this problem.
Comment 1 Victor Ashik 2003-08-11 04:41:58 EDT

*** This bug has been marked as a duplicate of 101977 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:58:03 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.