Bug 1019782 - Installation fails with special character on the path
Installation fails with special character on the path
Status: CLOSED CANTFIX
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Installer (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity urgent
: ---
: 6.0.0
Assigned To: Thomas Hauser
Len DiMaggio
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-16 08:00 EDT by Pavol Srna
Modified: 2013-12-12 11:40 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-12 11:40:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (42.19 KB, image/png)
2013-10-16 08:00 EDT, Pavol Srna
no flags Details

  None (edit)
Description Pavol Srna 2013-10-16 08:00:31 EDT
Created attachment 812878 [details]
screenshot

Description of problem:

mkdir called for example "รด" and try to install to that directory.
Comment 2 Pavol Srna 2013-10-16 08:19:53 EDT
Installer can finish without errors on RHEL, but the runtime starts with errors.
Comment 3 Len DiMaggio 2013-10-16 10:54:04 EDT
Just to be clear - This is not an issue for the space character
Comment 4 Miles Tjandrawidjaja 2013-10-17 15:50:02 EDT
Hello,
The latest installer should not fail since path containing the special character is not hard-coded. 

A bug has been submitted for solution of root problem at
https://bugzilla.redhat.com/show_bug.cgi?id=1020510
Comment 5 Thomas Hauser 2013-10-24 10:05:36 EDT
This issue will appear whenever the user uses an h2 database in a hardcoded path that contains special characters, due to Miles' explanation above.
Comment 6 Thomas Hauser 2013-11-19 12:06:41 EST
This issue cannot be resolved in the installer's end.

Note You need to log in before you can comment on or make changes to this bug.