Bug 1019804 - cinder: 'Module backports was already imported' when running cinder cli
cinder: 'Module backports was already imported' when running cinder cli
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-cinderclient (Show other bugs)
4.0
x86_64 Linux
unspecified Severity high
: beta
: 4.0
Assigned To: Jakub Ruzicka
Yogev Rabl
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-16 08:46 EDT by Dafna Ron
Modified: 2016-04-26 10:11 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 19:28:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1240497 None None None Never

  None (edit)
Description Dafna Ron 2013-10-16 08:46:08 EDT
Description of problem:

[root@cougar06 tmp(keystone_admin)]# cinder list 
/usr/lib/python2.6/site-packages/babel/__init__.py:33: UserWarning: Module backports was already imported from /usr/lib64/python2.6/site-packages/backports/__init__.pyc, but /usr/lib/python2.6/site-packages is being added to sys.path
  from pkg_resources import get_distribution, ResolutionError

root@cougar06 tmp(keystone_admin)]# cinder show 25b3b331-f736-4aa5-b77e-059b049ce092
/usr/lib/python2.6/site-packages/babel/__init__.py:33: UserWarning: Module backports was already imported from /usr/lib64/python2.6/site-packages/backports/__init__.pyc, but /usr/lib/python2.6/site-packages is being added to sys.path
  from pkg_resources import get_distribution, ResolutionError


Version-Release number of selected component (if applicable):

python-cinder-2013.2-0.11.rc1.el6ost.noarchopenstack-cinder-2013.2-0.11.rc1.el6ost.noarch

How reproducible:

100%

Steps to Reproduce:
1. install openstack with packstack with gluster backend 
2. run cinder cli commands
3.

Actual results:

/usr/lib/python2.6/site-packages/babel/__init__.py:33: UserWarning: Module backports was already imported from /usr/lib64/python2.6/site-packages/backports/__init__.pyc, but /usr/lib/python2.6/site-packages is being added to sys.path
  from pkg_resources import get_distribution, ResolutionError

Expected results:

seems we have a problem with the cli

Additional info:
Comment 1 Jakub Ruzicka 2013-10-30 08:45:37 EDT
I can't reproduce this on RHEL 6.5 beta with latest RHOS puddle. 

Also, this warning doesn't seem related to gluster cinder backend as cinderclient doesn't care about such things.

Can you reproduce this with latest puddle? Did you do something extra beyond packstack install?
Comment 2 Dafna Ron 2013-10-30 08:55:03 EDT
yep, its no longer happening in the latest puddle. 
However, you should know that I am working with the rdo package: 
python-backports-1.0-4.el6.x86_64.rpm

if this package has no effect at all on cli please move this to on_qa for latest build and I will move to verify.
Comment 3 Jakub Ruzicka 2013-10-31 05:56:13 EDT
That version contains Pádraig's quick fix.

However, I can't reproduce even with RHOS
python-backports-ssl_match_hostname-3.2-0.2.1.a3.el6.noarch

I'm moving to ON_QA as requested, but I think it's worth an additional check by someone else then me before moving to VERIFIED.

Párdaig, do you know what triggered this? Can it happen in RHOS?
Comment 4 Pádraig Brady 2013-10-31 06:39:02 EDT
There may be some mixing of RDO and RHOS going on here.
We shouldn't do that ask it may mask/cause various issues.
A guess is the RHOS system under test had python-backports-1.0-3 installed
which triggers the issues in the keystone puppet modules at least.
Comment 5 Yogev Rabl 2013-11-05 06:56:21 EST
verified with version: openstack-cinder-2013.2-1.el6ost.noarch
Comment 7 Scott Lewis 2013-12-16 13:56:40 EST
Auto qa_ack+ for VERIFIED bugs so they can be added to RC erratum
Comment 10 errata-xmlrpc 2013-12-19 19:28:43 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.