Bug 1019848 - plan prompt for test server is confusing
plan prompt for test server is confusing
Status: CLOSED CURRENTRELEASE
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (harness) (Show other bugs)
1.7.0
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Greg Nichols
William Gomeringer
:
Depends On:
Blocks: 1016295
  Show dependency treegraph
 
Reported: 2013-10-16 09:39 EDT by Petr Beňas
Modified: 2016-07-05 13:52 EDT (History)
5 users (show)

See Also:
Fixed In Version: hwcert-client 1.7.0-20131219
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1045134 (view as bug list)
Environment:
Last Closed: 2016-07-05 13:52:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch modify the prompt to make it a bit more clear for users (1005 bytes, patch)
2013-12-17 00:51 EST, Dong Zhu
dZhu: review? (gnichols)
Details | Diff

  None (edit)
Description Petr Beňas 2013-10-16 09:39:42 EDT
Description of problem:
hwcert-backend plan is stuck on 'Local Hardware Certification Test Server: '

Version-Release number of selected component (if applicable):
hwcert-client-1.7.0-61.el7.noarch, in R60 as well

How reproducible:
100%

Steps to Reproduce:
1. installl hwcert-client
2. hwcert-backend plan
3. Enter, Enter, Enter, Enter, "Server", "none"

Actual results:
Hardware: empty empty empty
OS: Maipo 7

Please verify the hardware product information:
    vendor:empty
    make:empty
    model:empty
    product-url:
    category (Desktop/Workstation|Laptop|Component/Peripheral|Server) Server
What certification is this system being tested for? (new|existing|none) none
response: none
Local Hardware Certification Test Server: 


Expected results:
planning is finished

Additional info:
Comment 1 Greg Nichols 2013-10-16 09:45:03 EDT
Is --mode set to "auto" ?   if not, did you enter anything for the test server?
Comment 2 Petr Beňas 2013-10-16 10:06:21 EDT
I have used no --mode or --server arguments, just "hwcert-backend plan". I was not asked for the server either.  But it looks like when --auto is used, this problem does not happen.
Comment 3 Greg Nichols 2013-10-16 11:47:53 EDT
I'm not clear on what the problem is then.   You should be able to enter the server host name, or leave it blank, and continue.
Comment 4 Petr Beňas 2013-10-17 05:48:39 EDT
I am terribly sorry, notabug. The hwcert is not stuck, but asking for the server. I was confused by wording of "Local Hardware Certification Test Server: " because it does not contain something like "Please enter" or a question mark. So my apologies, it is not a bug.
Comment 5 Greg Nichols 2013-10-17 09:13:42 EDT
If it confused you, it's a bug.

Let's leave it open - perhaps we could make the prompt a bit more clear with "Please enter".
Comment 6 Dong Zhu 2013-12-17 00:51:02 EST
Created attachment 837565 [details]
patch modify the prompt to make it a bit more clear for users

Note You need to log in before you can comment on or make changes to this bug.