Bug 101989 - hotplug does not update hwconf database
hotplug does not update hwconf database
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: hotplug (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-08 13:39 EDT by jmccann
Modified: 2015-01-14 18:19 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-04 15:53:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description jmccann 2003-08-08 13:39:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030701

Description of problem:
It seems that USB hotplug does not update the hwconf database.  Kudzu is not run.

The updfstab command *is* run but it relies on information being added to hwconf.

The kernel detects and configures /dev/sd* correctly.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Attach USB flash card 

Actual Results:  Nada.

Expected Results:  Ideally /mnt/flash will be mounted but I'll settle for it
being added to /etc/fstab.



Additional info:

I was able to fix this with the following patch:
% diff -u /etc/hotplug/hotplug.functions{.original,}
--- hotplug.functions.original  2003-08-08 13:07:31.000000000 -0400
+++ hotplug.functions   2003-08-08 12:47:12.000000000 -0400
@@ -170,6 +170,7 @@
            fi
        fi
        if echo "$MODULE" | grep -q "usb-storage" > /dev/null 2>&1 ; then
+           [ -x /usr/sbin/kudzu ] &&  /usr/sbin/kudzu -s
            [ -x /usr/sbin/updfstab ] &&  /usr/sbin/updfstab
        fi
     done
Comment 1 Bill Nottingham 2003-08-08 14:49:41 EDT
This actually works for you? It shouldn't.
updfstab does its own probing unless run with --skipprobe; calling kudzu
shouldn't make any difference at all.

I'd guess it's because of the delay when the device is created and the partition
table is read/recognized.
Comment 2 jmccann 2003-08-08 15:26:17 EDT
You are right about kudzu not being required for the device to be added to
fstab.  I think was confused by bug 101990.  However, the subject line of this
bug is still valid.  The hwconf database should get updated when hardware is
added (and when removed).
Comment 3 Bill Nottingham 2005-02-04 15:53:24 EST
Closing out bugs on older, no longer supported, releases. Apologies
for any lack of response. Please reopen if problems persist on more
current releases.

This won't be changed in hotplug/kudzu; future releases do update the
HAL hardware database on hotplug.

Note You need to log in before you can comment on or make changes to this bug.