Bug 1019920 - Products page doesn't render repos that exist in the database
Products page doesn't render repos that exist in the database
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.2
All All
high Severity high (vote)
: Unspecified
: --
Assigned To: Walden Raines
Garik Khachikyan
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-16 11:50 EDT by Walden Raines
Modified: 2015-01-04 17:00 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Walden Raines 2013-10-16 11:50:31 EDT
Description of problem:

Repositories for custom products aren't displayed after they are created.  Could be for the first product only.

How reproducible:

First custom product only?

Steps to Reproduce:
1. Create a custom product
2. Create a puppet repository
3. Reload the product's repository page
4. Note that repositories are not displayed

Actual results:

Newly created repositories are not displayed.

Expected results:

Newly created repositories should be displayed.

Additional info:
Comment 2 Walden Raines 2013-10-16 16:10:13 EDT
This is fixed in the new UI:

I now see:

Error occurred saving:
Validation failed: Keyname is too long (maximum is 255 characters), Value is too long (maximum is 255 characters)

and

Error occurred saving:
Validation failed: Value is too long (maximum is 255 characters)

when trying this.
Comment 3 Walden Raines 2013-10-16 16:10:53 EDT
(In reply to Walden Raines from comment #2)
> This is fixed in the new UI:
> 
> I now see:
> 
> Error occurred saving:
> Validation failed: Keyname is too long (maximum is 255 characters), Value is
> too long (maximum is 255 characters)
> 
> and
> 
> Error occurred saving:
> Validation failed: Value is too long (maximum is 255 characters)
> 
> when trying this.

Arg! Wrong bug, disregard.
Comment 4 Walden Raines 2013-10-17 16:15:25 EDT
This seems to be caused by upgrading only the rpm and running katello-configure without reindexing.  I was able to reproduce this issue after upgrading the katello rpm and running katello-configure but after I reindexed everything was as expected.

Moving this to ON_QA for verification.
Comment 5 Garik Khachikyan 2013-10-21 07:27:38 EDT
# VERIFIED

works for me... all both types of repos were prepared ok and the refresh just shows them all.

btw: we seems not support upgrades between the MDP-s - so I consider the issue as resolved. thanks.

===
* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.8.25-1.el6sam.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.25-1.el6sam.noarch
* candlepin-tomcat6-0.8.25-1.el6sam.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* foreman-1.3.0-18.el6sat.noarch
* foreman-compute-1.3.0-18.el6sat.noarch
* foreman-libvirt-1.3.0-18.el6sat.noarch
* foreman-postgresql-1.3.0-18.el6sat.noarch
* foreman-proxy-1.3.0-3.el6sat.noarch
* katello-1.4.6-39.el6sat.noarch
* katello-all-1.4.6-39.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.4-1.el6sat.noarch
* katello-cli-1.4.3-24.el6sat.noarch
* katello-cli-common-1.4.3-24.el6sat.noarch
* katello-common-1.4.6-39.el6sat.noarch
* katello-configure-1.4.7-5.el6sat.noarch
* katello-configure-foreman-1.4.7-5.el6sat.noarch
* katello-configure-foreman-proxy-1.4.7-5.el6sat.noarch
* katello-foreman-all-1.4.6-39.el6sat.noarch
* katello-glue-candlepin-1.4.6-39.el6sat.noarch
* katello-glue-elasticsearch-1.4.6-39.el6sat.noarch
* katello-glue-pulp-1.4.6-39.el6sat.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-1.4.4-4.el6sat.noarch
* openldap-2.4.23-31.el6.x86_64
* pulp-katello-plugins-0.2-1.el6sat.noarch
* pulp-nodes-common-2.3.0-0.22.beta.el6sat.noarch
* pulp-nodes-parent-2.3.0-0.22.beta.el6sat.noarch
* pulp-puppet-plugins-2.3.0-0.22.beta.el6sat.noarch
* pulp-rpm-plugins-2.3.0-0.22.beta.el6sat.noarch
* pulp-selinux-2.3.0-0.22.beta.el6sat.noarch
* pulp-server-2.3.0-0.22.beta.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.2.2-2.el6sat.noarch
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.0.7-1.el6sat.noarch
* signo-0.0.22-2.el6sat.noarch
* signo-katello-0.0.22-2.el6sat.noarch
Comment 6 Bryan Kearney 2014-04-24 13:11:28 EDT
This was verified and delivered with MDP2. Closing it out.
Comment 7 Bryan Kearney 2014-04-24 13:12:20 EDT
This was delivered and verified with MDP2. Closing the bug.

Note You need to log in before you can comment on or make changes to this bug.