Bug 1019922 - gnome-initial-setup enterprise login feature doesn't work
gnome-initial-setup enterprise login feature doesn't work
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-initial-setup (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jasper St. Pierre
Desktop QE
:
Depends On: 1019925
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-16 11:52 EDT by Ray Strode [halfline]
Modified: 2014-06-13 05:33 EDT (History)
4 users (show)

See Also:
Fixed In Version: 0.13.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1019925 (view as bug list)
Environment:
Last Closed: 2014-06-13 05:33:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ray Strode [halfline] 2013-10-16 11:52:19 EDT
The version of gnome-initial-setup we ship in RHEL 7 is pretty old.  It's missing a number of fixes that are needed to make it work with red hat's kerberos setup.

trying to use it on REDHAT.COM yields:

Couldn't read default naming context
 ! Couldn't look up domain name in LDAP server

I think we should probably update it to the latest version or at least pull in the fixes Stefw did to it:

https://git.gnome.org/browse/gnome-initial-setup/commit/?id=7e33d3a164667089aef9604a5bfa28489ffde17c

(and the adjacent earlier commits)
Comment 1 Ray Strode [halfline] 2013-10-16 11:57:51 EDT
Looks like this also fails with control-center, i'll clone this bug against realmd.
Comment 3 Matthias Clasen 2013-11-08 10:09:48 EST
Jasper says the required patches are included in gnome-initial-setup now.
Comment 4 Michal Kovarik 2014-01-30 03:46:19 EST
Verified on gnome-initial-setup-0.13.1-3. I was able to connect to REDHAT.COM kerberos realm in gnome-initial-setup
Comment 5 Ludek Smid 2014-06-13 05:33:29 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.