Bug 1020044 - accountsservice needs fix for gnome unlock screen
accountsservice needs fix for gnome unlock screen
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: accountsservice (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Ray Strode [halfline]
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-16 17:00 EDT by Ray Strode [halfline]
Modified: 2014-09-13 14:57 EDT (History)
2 users (show)

See Also:
Fixed In Version: accountsservice-0.6.35-1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 05:56:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ray Strode [halfline] 2013-10-16 17:00:04 EDT
GNOME's unlock screen will avoid locking if it thinks the user has no password.  accountsservice incorrectly says the user has no password for remote users.

We need this fix:

http://cgit.freedesktop.org/accountsservice/commit/?id=631c57790fe79ee70d79522eb1b3e461e2899d82

user: treat NULL shadow entry as "password handled remotely"

Right now we set the password mode of a user based on the password hash in shadow. SSSD (and other remote login facilities presumably) don't send the password hash over the wire to the client, but of course those users do have a password set. This commit changes the code to notice when there's no shadow entry for a user and treat that case conservatively (assume user has a password). 

Related to: https://bugzilla.gnome.org/show_bug.cgi?id=708997 
https://bugs.freedesktop.org/show_bug.cgi?id=70005 

Though, if bug 1019488 goes through, we can just close this bug, since 0.6.35 includes the fix.
Comment 1 Ray Strode [halfline] 2013-10-28 10:10:27 EDT
(bug 1019488 went through, so we can close this one too)
Comment 5 Ludek Smid 2014-06-13 05:56:03 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.