Bug 1020154 - RC bug: Total size of master greater than slave
RC bug: Total size of master greater than slave
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: geo-replication (Show other bugs)
mainline
All Linux
high Severity high
: ---
: ---
Assigned To: Ajeet Jha
:
Depends On: 1007536 1110672 1162140
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-17 03:24 EDT by Ajeet Jha
Modified: 2015-02-22 18:01 EST (History)
10 users (show)

See Also:
Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1007536
Environment:
Last Closed: 2014-04-17 07:49:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Anand Avati 2013-10-17 04:19:43 EDT
REVIEW: http://review.gluster.org/6102 (geo-rep: Increasing the buffer_size for master-salve size comparision.) posted (#1) for review on master by ajeet jha (ajha@redhat.com)
Comment 2 Anand Avati 2013-10-22 08:04:30 EDT
REVIEW: http://review.gluster.org/6102 (geo-rep: Increasing the buffer_size for master-salve size comparision.) posted (#2) for review on master by ajeet jha (ajha@redhat.com)
Comment 3 Anand Avati 2013-10-24 17:23:11 EDT
COMMIT: http://review.gluster.org/6102 committed in master by Anand Avati (avati@redhat.com) 
------
commit ef4bb42382a5c9c3ca0907136669a659c2a20311
Author: Ajeet Jha <ajha@redhat.com>
Date:   Thu Oct 17 13:14:02 2013 +0530

    geo-rep: Increasing the buffer_size for master-salve size comparision.
    
    The buffer size is increased to 100MB, considering the space required by slave
    filesystem bookkeeping.
    
    Change-Id: Ib296f0e03b4d7a2de6d5ff0ae9ab09a5261e3e7c
    BUG: 1020154
    Signed-off-by: Ajeet Jha <ajha@redhat.com>
    Reviewed-on: http://review.gluster.org/6102
    Reviewed-by: Avra Sengupta <asengupt@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
Comment 4 Anand Avati 2014-01-28 20:48:56 EST
REVIEW: http://review.gluster.org/6844 (geo-replication: gverify should use available_size not 1K-blocks for master_stats) posted (#1) for review on master by Harshavardhana (harsha@harshavardhana.net)
Comment 5 Anand Avati 2014-02-04 03:47:50 EST
REVIEW: http://review.gluster.org/6844 (geo-replication: gverify should use disk_size and available_size) posted (#2) for review on master by Harshavardhana (harsha@harshavardhana.net)
Comment 6 Anand Avati 2014-02-06 10:31:51 EST
COMMIT: http://review.gluster.org/6844 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 055c02436fd6ef6984468b33158104770b41e422
Author: Harshavardhana <harsha@harshavardhana.net>
Date:   Tue Jan 28 17:42:21 2014 -0800

    geo-replication: gverify should use disk_size and available_size
    
    "commit ef4bb42382a5c9c3ca0907136669a659c2a20311" was incomplete since
    reduction in sizes doesn't really have any affect on the problem when
    disks sizes are similar.
    
    Actual fix is to verify disk_size and then verify available_size
    
    Change-Id: Idb57f606df229c0bdaeda8852c74e84d29109ffc
    BUG: 1020154
    Signed-off-by: Harshavardhana <harsha@harshavardhana.net>
    Reviewed-on: http://review.gluster.org/6844
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Venky Shankar <vshankar@redhat.com>
Comment 7 Niels de Vos 2014-04-17 07:49:46 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.