Bug 1020166 - python eggs depending on openlmi-tools can not install
python eggs depending on openlmi-tools can not install
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openlmi-tools (Show other bugs)
20
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Peter Hatina
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1019603
  Show dependency treegraph
 
Reported: 2013-10-17 03:47 EDT by Michal Minar
Modified: 2013-10-23 08:32 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-23 08:32:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Minar 2013-10-17 03:47:54 EDT
Description of problem:
  openlmi-tools has wrong python dependencies. Its egg has 'lmi' in required that does not name any python egg. Any python eggs requiring openlmi-tools then fail to build and install due to missing 'lmi' dependency.

Version-Release number of selected component (if applicable):
  0.7-1.fc20

How reproducible:
  ALWAYS

Steps to Reproduce:
1. install openlmi-tools
2. try to install any python egg depending on openlmi-tools (for example: https://github.com/openlmi/openlmi-scripts/releases/tag/0.2.3)

Actual results:
  Installation fails due to missing 'lmi' dependency.
 
Expected results:
  Installation completes.


Additional info:
  It's already solved in upstream. Rebase will solve this.
Comment 1 Peter Hatina 2013-10-23 08:32:53 EDT
Fixed rebase to openlmi-tools-0.8-1.fc21.

http://koji.fedoraproject.org/koji/taskinfo?taskID=6090003

Note You need to log in before you can comment on or make changes to this bug.