Bug 1020195 - RBAC: Changing scope type of the role leads to "Failed to save" error
RBAC: Changing scope type of the role leads to "Failed to save" error
Status: CLOSED DUPLICATE of bug 1020196
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Web Console (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Heiko Braun
Jakub Cechacek
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-17 05:10 EDT by Jakub Cechacek
Modified: 2015-02-01 18:00 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-21 05:23:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jakub Cechacek 2013-10-17 05:10:46 EDT
Attempting to change scope type of existing scoped role leads to error on save. 

Steps to Reproduce:
1. navigate to Administration - Role Assignment - Roles - Scoped Roles
2. create role of group scoped role restricted to main-server-group
3. select the role created in previous step in the list and click "edit" button
4. change type to "Host" and select the scope (e.g. master host)
5. save 

Actual results:
"Failed to save error message"

Expected results:
As both "Host" and "Server group" scoped roles are a different type of resource, it should not be possible to modify the scope type of existing roles.

Proposed fix:
Remove the option to change scope type
Comment 1 Harald Pehl 2013-10-21 05:23:58 EDT

*** This bug has been marked as a duplicate of bug 1020196 ***

Note You need to log in before you can comment on or make changes to this bug.