Bug 1020196 - RBAC: Changing scope type of the role leads to "Failed to save" error
RBAC: Changing scope type of the role leads to "Failed to save" error
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Web Console (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity urgent
: ER7
: EAP 6.2.0
Assigned To: Heiko Braun
Jakub Cechacek
Russell Dickenson
:
: 1020195 (view as bug list)
Depends On:
Blocks: 1021418
  Show dependency treegraph
 
Reported: 2013-10-17 05:10 EDT by Jakub Cechacek
Modified: 2015-02-01 18:00 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:14:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker HAL-284 Major Resolved Changing scope type of the role leads to "Failed to save" error 2013-11-21 18:48:14 EST

  None (edit)
Description Jakub Cechacek 2013-10-17 05:10:56 EDT
Attempting to change scope type of existing scoped role leads to error on save. 

Steps to Reproduce:
1. navigate to Administration - Role Assignment - Roles - Scoped Roles
2. create role of group scoped role restricted to main-server-group
3. select the role created in previous step in the list and click "edit" button
4. change type to "Host" and select the scope (e.g. master host)
5. save 

Actual results:
"Failed to save error message"

Expected results:
As both "Host" and "Server group" scoped roles are a different type of resource, it should not be possible to modify the scope type of existing roles.

Proposed fix:
Remove the option to change scope type
Comment 1 JBoss JIRA Server 2013-10-18 08:56:54 EDT
Harald Pehl <hpehl@redhat.com> updated the status of jira HAL-284 to Coding In Progress
Comment 2 JBoss JIRA Server 2013-10-18 09:00:00 EDT
Harald Pehl <hpehl@redhat.com> updated the status of jira HAL-284 to Resolved
Comment 3 JBoss JIRA Server 2013-10-18 09:00:00 EDT
Harald Pehl <hpehl@redhat.com> made a comment on jira HAL-284

Type is read-only in edit mode
Comment 4 Harald Pehl 2013-10-21 05:23:58 EDT
*** Bug 1020195 has been marked as a duplicate of this bug. ***
Comment 5 Jakub Cechacek 2013-10-31 06:28:23 EDT
Verified 6.2.0.,ER7

Note You need to log in before you can comment on or make changes to this bug.