Bug 1020230 - [AFR][RFE]: Need a definitive way to figure out if SELF HEAL has completed on a volume
[AFR][RFE]: Need a definitive way to figure out if SELF HEAL has completed on...
Status: CLOSED DUPLICATE of bug 986317
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: replicate (Show other bugs)
2.1
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Bug Updates Notification Mailing List
Sudhir D
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-17 06:28 EDT by Sachidananda Urs
Modified: 2016-09-17 08:12 EDT (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.6.0-3.0.el6rhs
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-14 02:16:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sachidananda Urs 2013-10-17 06:28:02 EDT
Description of problem:

While doing rolling upgrades, as a first step we bring down one of the nodes and upgrade it. And to continue upgrading the replica, we wait till the data is self-healed on the node which was brought down. However, currently the heal info command does not definitively provide information whehter self-heal is complete.

Ref: Bug: 986317
Comment 1 Sachidananda Urs 2013-10-17 06:28:26 EDT
https://bugzilla.redhat.com/show_bug.cgi?id=986317
Comment 2 Sachidananda Urs 2013-10-17 06:34:22 EDT
[root@boggs ~]# gluster volume heal pure_gold info|wc -l
152
[root@boggs ~]# gluster volume heal pure_gold info|wc -l
16
[root@boggs ~]# gluster volume heal pure_gold info|wc -l
51
[root@boggs ~]# gluster volume heal pure_gold info|wc -l
153
[root@boggs ~]# gluster volume heal pure_gold info|wc -l
190
[root@boggs ~]# gluster volume heal pure_gold info|wc -l
145

The output is very inconsistent.
Comment 4 Sachidananda Urs 2013-10-17 07:14:15 EDT
Upon self-heal completion, a status message like. All entries self-healed, nothing more to self-heal... should be useful.
Comment 5 Pranith Kumar K 2014-05-14 02:16:09 EDT

*** This bug has been marked as a duplicate of bug 986317 ***

Note You need to log in before you can comment on or make changes to this bug.