Bug 1020336 - Virt-manager doesn't show an error message for vfio device failure
Virt-manager doesn't show an error message for vfio device failure
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
19
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-17 09:11 EDT by James Hubbard
Modified: 2013-11-15 08:34 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-15 08:34:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Hubbard 2013-10-17 09:11:02 EDT
Description of problem:
virt-manager fails to show an error message when a pci device doesn't work and the VM failes to start. 

This is the error message generated from the command line.
# virsh start win7pro-cli5
error: Failed to start domain win7pro-cli5
error: internal error: Invalid device 0000:83:00.0 driver file /sys/bus/pci/devices/0000:83:00.0/driver is not a symlink

Version-Release number of selected component (if applicable):
Fedora 19 with the virt-preview repository enabled.
libvirt: 1.1.3-2.fc19.x86_64
virt-manager: virt-manager-0.10.0-4.git79196cdf.fc19
uname: 3.11.4-201.fc19.x86_64 #1 SMP Thu Oct 10 14:11:18 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

How reproducible:
Always

Actual results:
virt-manager doesn't print error message.

Expected results:
error message stating that vm failed to start and the output regarding why. A message like this perhaps: error: internal error: Invalid device 0000:83:00.0 driver file /sys/bus/pci/devices/0000:83:00.0/driver is not a symlink

Additional info:
Prior to upgrading to virt-preview I was getting messages about not being able to do a bus reset. 

I created a bug report about vfio issues #1020326
Comment 1 Cole Robinson 2013-11-09 17:58:21 EST
Hmm, I can't reproduce here, VM startup errors are reported correctly.

Can you reproduce with virt-manager --debug, and attach all the output here?
Comment 2 James Hubbard 2013-11-15 08:34:42 EST
I updated this morning and it appears to be working for me as well.  I'll close it.

Note You need to log in before you can comment on or make changes to this bug.