Bug 1020409 - Product deletion refreshes pools for entire org
Product deletion refreshes pools for entire org
Status: CLOSED NOTABUG
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Repositories (Show other bugs)
6.0.2
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-17 11:37 EDT by Justin Sherrill
Modified: 2017-02-12 22:27 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-02-12 22:27:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Sherrill 2013-10-17 11:37:16 EDT
Description of problem:

Currently when you delete a product it calls Resources::Candlepin::Subscription.refresh_for_owner() which refreshes the pools for a systems within the organization.

This is extremely slow when you have lots of systems


How reproducible:
always

Steps to Reproduce:
1.  Register ~200 systems
2.  Create a product, do not create a repo, do not assign systems to it
3.  Delete the product

Actual results:
Very slow (~60 seconds)


Expected results:
Should be fast

Additional info:
As far as I know there is no reason to refresh the pools for all systems in the org
Comment 1 Justin Sherrill 2013-10-17 11:38:41 EDT
Ideally this shouldn't block the request regardless as well, it should occur in the background.
Comment 2 RHEL Product and Program Management 2013-10-17 11:56:03 EDT
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 6 Justin Sherrill 2017-02-12 22:27:47 EST
Looks like this was removed from Product delete some where before 6.2 but was still being called during product create.  It was removed as part of the candlepin 2.0 work.  I'll go ahead and close this as I don't know that this is affecting customers.

Note You need to log in before you can comment on or make changes to this bug.