Bug 1020476 - katello-disconnected: enable/disable invalid repo passes.
katello-disconnected: enable/disable invalid repo passes.
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Inter Satellite Sync (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Mike McCune
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-17 14:10 EDT by Apurva Bhole
Modified: 2016-02-08 13:23 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-08 13:23:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Apurva Bhole 2013-10-17 14:10:58 EDT
Description of problem:
disabling a non-existing repo, enabling a non-existing/already enabled repo seems to pass.
It should fail with a suitable error message.

Version-Release number of selected component (if applicable):
pulp-katello-plugins-0.2-1.el6sat.noarch
katello-glue-elasticsearch-1.4.6-31.el6sat.noarch
katello-glue-pulp-1.4.6-31.el6sat.noarch
katello-common-1.4.6-31.el6sat.noarch
katello-1.4.6-31.el6sat.noarch
katello-glue-candlepin-1.4.6-31.el6sat.noarch
katello-utils-1.4.3-4.el6sat.noarch
katello-selinux-1.4.4-4.el6sat.noarch
signo-katello-0.0.22-2.el6sat.noarch
katello-repos-1.5.1-1.fc18.noarch

How reproducible:
Always

Steps to Reproduce:
1. katello-disconnected import -m manifest.zip
2. katello-disconnected disable -r rhel-workstation-dts-6-rhb-source-rpms-6Workstation-x86_64
3. katello-disconnected disable -r rhel-workstation-dts-6-rhb-source-rpms-6Workstation-x86_64
4. katello-disconnected disable -r invalid-name

5. katello-disconnected enable -r rhel-workstation-dts-6-rhb-source-rpms-6Workstation-x86_64
6. katello-disconnected enable -r rhel-workstation-dts-6-rhb-source-rpms-6Workstation-x86_64
7. katello-disconnected enable -r invalid-name

Actual results:
All the steps pass without any message.

Expected results:
Steps 3,4, 6,7 should fail

Additional info:
Comment 1 RHEL Product and Program Management 2013-10-17 14:25:47 EDT
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 6 Bryan Kearney 2016-02-08 13:23:16 EST
The katello-disconnected server synchronization and export functions are being moved into the Satellite server itself. With 6.2, the katello-disconnected command will no longer be delivered and instead will be replaced with a new export and import functions delivered via the UI and hammer CLI. This bug is being closed as "WONTFIX" since it relates only to the existing katello-disconnected tooling. Please check the Satellite docs with the release of Satellite 6.2 on how to use the new content export and import features.

Note You need to log in before you can comment on or make changes to this bug.