Bug 1020500 - need stapvirt feature
need stapvirt feature
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: systemtap (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: beta
: ---
Assigned To: Frank Ch. Eigler
Martin Cermak
: Rebase
Depends On: 1038989
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-17 15:02 EDT by Jonathan Lebon
Modified: 2014-06-18 00:17 EDT (History)
3 users (show)

See Also:
Fixed In Version: systemtap-2.4-1.el7
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 06:30:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Descrition of cross-vm feature and testing ideas (4.52 KB, text/plain)
2013-10-17 15:02 EDT, Jonathan Lebon
no flags Details

  None (edit)
Description Jonathan Lebon 2013-10-17 15:02:51 EDT
Created attachment 813516 [details]
Descrition of cross-vm feature and testing ideas

A new feature was recently added to the systemtap master branch which will allow users to perform cross-vm instrumentation using a virtio-serial channel. (Related commits 59bbd46 to 765a5d6).

It would be great if we could rebase to include this feature. I've attached a document providing more details on the feature and how it could be tested.

Thanks,

Jonathan
Comment 1 Jonathan Lebon 2013-10-18 10:15:37 EDT
As a test, I successfully ran check.exp with all the examples modified to run on my virtual machine. I used the following one-liner (from the testsuite/systemtap.examples directory):

find . -iname '*.meta' | xargs -n 1 sed -i '/^test_installcheck: stap/ s/$/ --remote libvirt:TestVM/'

Hope this helps!
Comment 17 Frank Ch. Eigler 2013-11-22 15:04:44 EST
The last_100_frees example seems to be failing because of:

WARNING: cannot find module /usr/lib64/libc-2.17.so debuginfo: No DWARF information found [man warning::debuginfo]
semantic error: while resolving probe point: identifier 'process' at last_100_frees.stp:5:7
        source: probe process("/lib*/libc.so.*").function("free") [...]

IOW glibc-debuginfo not installed.  The testsuite does not rpm-prereq it,
but this test case needs it.
Comment 39 Ludek Smid 2014-06-13 06:30:30 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.