Bug 1020539 - RHEL 7 Firstboot: No option to register with proxy
RHEL 7 Firstboot: No option to register with proxy
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: candlepin-bugs
John Sefler
:
Depends On:
Blocks: rhsm-rhel70
  Show dependency treegraph
 
Reported: 2013-10-17 17:07 EDT by Sharath Dwaral
Modified: 2015-03-22 21:14 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Known Issue
Doc Text:
The option to register using a proxy server has been removed along with the removal of Red Hat network (RHN) registration support from the firstboot tool in Red Hat Enterprise Linux 7.0 Beta. As a consequence, if the proxy settings is required during registration using the Subscription Manager utility, the installation cannot finish successfully. To work around this problem, skip the registration procedure in Subscription Manager during the firstboot stage and open the Subscription Manager GUI, which allows you to set the proxy server followed by registration using the Red Hat Subscription Manager (RHSM).
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 08:06:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
firstboot rhel7 no proxy option (48.97 KB, image/png)
2013-10-17 17:07 EDT, Sharath Dwaral
no flags Details
RHEL7-Firstboot-Proxy (69.15 KB, image/png)
2013-12-16 11:46 EST, Sharath Dwaral
no flags Details

  None (edit)
Description Sharath Dwaral 2013-10-17 17:07:32 EDT
Created attachment 813551 [details]
firstboot rhel7 no proxy option

Description of problem:
RHEL 7 First boot has no option to register with proxy

Version-Release number of selected component (if applicable):
# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.8.29-1
subscription-manager: 1.10.4-1.el7
python-rhsm: 1.10.3-1.el7


How reproducible:
Always

Steps to Reproduce:
1. Start Firstboot 
2. click Next 

Actual results:
See attachment

Expected results:
There should be an option to register with proxy

Additional info:
Comment 1 Adrian Likins 2013-10-18 13:36:56 EDT
Looks like the logic for deciding when to show the proxy info isn't quite right.
For 9ebbf0b4b2aaf8cfc3c5f416d2c6640566a8e253 (, 1.10.4) we only show our proxy config infomation if the system doesn't have any rhn config (ie, no rhn-client-tools installed).

That's not really correct, since you could have that installed, even if it's not actually needed by us or firstboot anymore. Code needs to figure out there are no rhn modules in firstboot (as on rhel7) and show the proxy config, and for rhel6, where there are rhn modules, to use the proxy info from the rhn screens.
Comment 3 Adrian Likins 2013-12-06 09:33:10 EST
commit f3c516ec155cc7ef3533464890f061393a575194
Author: Adrian Likins <alikins@redhat.com>
Date:   Thu Nov 21 16:24:05 2013 -0500

    1020539: Show proxy info if no RHN in firstboot
    
    Previously, we used the http proxy info collected
    in the RHN firstboot screens. If we are standalone
    without those modules, show our proxy screen instead.
Comment 5 Sharath Dwaral 2013-12-16 11:46:19 EST
Created attachment 837332 [details]
RHEL7-Firstboot-Proxy

Version
# subscription-manager version
server type: This system is currently not registered.
subscription management server: 0.9.1-1
subscription-manager: 1.10.8-1.el7
python-rhsm: 1.10.8-1.el7

Verification:

Please see attachment.

Verified for 
1. Proxy with auth
2. Proxy without auth

VERIFIED
Comment 6 Ludek Smid 2014-06-13 08:06:22 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.