Bug 1020583 - Can't set swap and logging partition to 0 as the prompt inforamtion says
Can't set swap and logging partition to 0 as the prompt inforamtion says
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.5
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Fabian Deutsch
Virtualization Bugs
:
Depends On: 1012323
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-17 23:04 EDT by wanghui
Modified: 2014-01-21 14:54 EST (History)
17 users (show)

See Also:
Fixed In Version: ovirt-node-3.0.1-5.el6
Doc Type: Bug Fix
Doc Text:
--no tech note required
Story Points: ---
Clone Of: 1012323
Environment:
Last Closed: 2014-01-21 14:54:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 19595 None None None Never

  None (edit)
Description wanghui 2013-10-17 23:04:08 EDT
+++ This bug was initially created as a clone of Bug #1012323 +++

Description of problem:
There is inaccurate prompt infos in storage volumes page during TUI installation. As the prompt info shows that the swap and logging partition can be set as 0. But after I setted swap and logging partition as 0, it can not finished the installation process.

Version-Release number of selected component (if applicable):
ovirt-node-iso-3.1.0-0.999.999.20130925204338gite3d4900.772.fc18.iso

How reproducible:
100%

Steps to Reproduce:
1. TUI install ovirt-node-iso-3.1.0-0.999.999.20130925204338gite3d4900.772.fc18.iso.
2. In storage volumes page, delete the swap, logging and data partitions size.
3. Set the swap and logging partitions as 0.

Actual results:
1. After step2, it prompt the swap and logging partitions can be setted as 0.
2. After step3, the installation will hang on partition process.

Expected results:
1. It will give the accurate prompt infos according to the minimum partition requirements.

Additional info:
Comment 1 wanghui 2013-10-17 23:07:09 EDT
Tested version:
rhev-hypervisor6-6.5-20131017.0.iso
ovirt-node-3.0.1-4.el6.noarch

This bug can be reproduced in this version. So it needed to be cloned to downstream to track this issue.
Comment 5 wanghui 2013-10-28 02:53:13 EDT
Test version:
rhevh-6.5-20131024.1.0.iso
ovirt-node-3.0.1-6.el6.noarch

Test steps:
1. Clear install rhevh-6.5-20131024.1.0.iso.
2. In storage volumes page, delete the swap, logging and data partitions size.
3. Set the swap and logging partitions as 0.
4. Set the swap and logging partitions as 5.

Test result:
1. After step3, it not allow user to set swap and logging partition to 0.
2. After step4, it installs successfully.

This bug is fixed in rhevh-6.5-20131024.1.0.iso. So change the status from ON_QA to VERIFIED.
Comment 8 Cheryn Tan 2013-11-07 19:36:26 EST
This bug is currently attached to errata RHBA-2013:15277. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 10 errata-xmlrpc 2014-01-21 14:54:41 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0033.html

Note You need to log in before you can comment on or make changes to this bug.