Bug 1020700 - dracut:FATAL:No netboot configured, bond is invalid when auto install with bond
dracut:FATAL:No netboot configured, bond is invalid when auto install with bond
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.5
Unspecified Unspecified
urgent Severity high
: rc
: ---
Assigned To: Fabian Deutsch
Virtualization Bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-18 04:02 EDT by haiyang,dong
Modified: 2014-12-08 10:07 EST (History)
13 users (show)

See Also:
Fixed In Version: ovirt-node-3.0.1-8.el6
Doc Type: Bug Fix
Doc Text:
Previously bond=<bondname>[:<bondslaves>:[:<options>]] was being used to setup "bond". The name "bond" was being recognized by dracut and causing kernel panic with "dracut:FATAL:No netboot configured, bond is invalid". This was caused by having duplicate names in the system. To fix this "bond" has been renamed as "bond_setup" to solve conflicting names. This information is used to setup bond during an auto-installation.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 14:54:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
attached Screenshot for kernel panic.png (14.32 KB, image/png)
2013-10-18 04:02 EDT, haiyang,dong
no flags Details

  None (edit)
Description haiyang,dong 2013-10-18 04:02:02 EDT
Created attachment 813643 [details]
attached Screenshot for kernel panic.png

Description of problem:
When try auto install to create bond with "bond" parameter.
It will kernel panic with print error info:
dracut:FATAL:No netboot configured, bond is invalid
dracut:Refusing to continue(Seen kernel panic.png)

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.5-20131017.0.iso
ovirt-node-3.0.1-4.el6
dracut-004-335.el6.noarch
dracut-kernel-004-335.el6.noarch
dracut-network-004-335.el6.noarch
dracut-fips-004-335.el6.noarch

     

How reproducible:
100%

Steps to Reproduce:


Actual results:

 
Expected results:


Additional info:
No this issue in rhev-hypervisor6-6.5-20130725.0.el6, so it's regression bug.
Comment 4 haiyang,dong 2013-10-31 05:31:25 EDT
The same issue could reproduce in the follow version:
rhevh-6.5-20131024.1.0.iso
ovirt-node-3.0.1-6.el6.noarch
dracut-fips-004-335.el6.noarch
dracut-004-335.el6.noarch
dracut-kernel-004-335.el6.noarch
dracut-network-004-335.el6.noarch

it blocked test case for auto install to create bond,so change "Priority"
into "urgent"
Comment 7 haiyang,dong 2013-12-14 00:27:51 EST
Test version:
ovirt-node-3.0.1-9.el6_5.noarch.rpm
rhevh-6.5-20131213.0.0.iso

Try auto install to create bond0 with "bond" parameter.
BOOTIF=eth0 storage_init=/dev/sda bond=bond0:eth1 firstboot

No kernel panic error info and create bond0 also successfully. so this bug has been fixed on ovirt-node-3.0.1-9.el6_5, after the status of this bug changed into "ON_QA", I will verify it.
Comment 8 haiyang,dong 2014-01-03 05:02:16 EST
Sorry my mistake for comment 7, the auto install to create bond0 should use "bond__setup" parameter:
BOOTIF=eth0 storage_init=/dev/sda bond_setup=bond0:eth1 firstboot

of course this bug has been fixed in rhevh-6.5-20131220.0,so change the status into "verified".
Comment 9 Cheryn Tan 2014-01-08 00:36:54 EST
This bug is currently attached to errata RHBA-2013:15277. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:
https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes

Thank you for your help.
Comment 10 Charlie 2014-01-13 00:44:32 EST
Ok I have most of it, I'm just not sure why "bond" being recognized by dracut caused the kernel error, read the gerrit note and and it seemed to indicate there was a conflict of names? can you clarify a bit more? thanks.
Comment 11 haiyang,dong 2014-01-16 03:29:11 EST
Also this bug was fixed in the follow version:
rhevh-6.5-20140110.1
ovirt-node-3.0.1-16.el6_5.noarch
Comment 13 errata-xmlrpc 2014-01-21 14:54:51 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0033.html

Note You need to log in before you can comment on or make changes to this bug.