Bug 1020791 - Zend Server page is unavailable after zend app created.
Zend Server page is unavailable after zend app created.
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Michal Fojtik
libra bugs
:
: 1020966 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-18 05:35 EDT by Qiushui Zhang
Modified: 2015-05-14 19:30 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-29 19:49:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs from instance (805.03 KB, application/zip)
2013-10-18 05:35 EDT, Qiushui Zhang
no flags Details
drupal ball (1.25 MB, application/zip)
2013-10-20 23:31 EDT, Qiushui Zhang
no flags Details

  None (edit)
Description Qiushui Zhang 2013-10-18 05:35:43 EDT
Created attachment 813683 [details]
logs from instance

Description of problem:
Create a zend app. Visit the Zend Server by app_url/ZendServer. Zend Server is unavailabe.

Version-Release number of selected component (if applicable):
devenv_3912

How reproducible:
always

Steps to Reproduce:
1. Create a zend app
rhc app create zd1 zend-5.6
2. Visit the web page:
https://zd1-qiuzhang.dev.rhcloud.com/ZendServer
3.

Actual results:
Zend Server is unavailable.

Expected results:
We could visit Zend Server successfully.

Additional info:
1.Restarting app will not help.
2. Please refer to the log attached to the bug.
3. The app web page is accessible.https://zd1-qiuzhang.dev.rhcloud.com
Comment 1 Dan McPherson 2013-10-18 14:58:53 EDT
From 1020966:

The pre-protocols behaviour was to assume http if a mapping was specified.

Stage:
https://github.com/openshift/origin-server/pull/3929

Master:
https://github.com/openshift/origin-server/pull/3930

Release ticket updated.
Comment 2 Dan McPherson 2013-10-18 14:59:08 EDT
*** Bug 1020966 has been marked as a duplicate of this bug. ***
Comment 3 Xiaoli Tian 2013-10-20 22:36:53 EDT
(In reply to Dan McPherson from comment #1)
> From 1020966:
> 
> The pre-protocols behaviour was to assume http if a mapping was specified.
> 
> Stage:
> https://github.com/openshift/origin-server/pull/3929
> 
> Master:
> https://github.com/openshift/origin-server/pull/3930
> 
> Release ticket updated.

It seems this bug can not be reproduced on current PROD, but we'll test if it still works after the fix.
Comment 4 Meng Bo 2013-10-20 22:40:59 EDT
Checked zend app on current PROD, the console page can be visited without problem,

And checked on current STG with the hotfix, the console page still works well.
Comment 5 Qiushui Zhang 2013-10-20 23:09:45 EDT
Tested on devenv_3921.
ZendServer can be accessed successfully.
Quickstart drupal can be deployed.

Mark the bug as verified.
Comment 6 Qiushui Zhang 2013-10-20 23:30:37 EDT
BTW, for the quickstart deployment mentioned in the last comments:
It is deployed from a prepared binary file. Please refer to the attached if interested in it.
Comment 7 Qiushui Zhang 2013-10-20 23:31:16 EDT
Created attachment 814392 [details]
drupal ball

Note You need to log in before you can comment on or make changes to this bug.