Bug 1020802 - Slic3r crashes when loading config
Slic3r crashes when loading config
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: slic3r (Show other bugs)
19
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Miro Hrončok
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-18 06:03 EDT by LAurent_B
Modified: 2013-10-22 00:57 EDT (History)
2 users (show)

See Also:
Fixed In Version: slic3r-0.9.10b-4.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-22 00:57:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description LAurent_B 2013-10-18 06:03:19 EDT
Description of problem:

Slic3r scrach with two different ways :

- first machine : when loadint a config.ini file
Can't call method config on an undefined value at /usr/share/perl5/vendor_perl/Slic3r/GUI/SkeinPanel.pm line 356 


- second machine : when slicing with a loaded config.ini file
Can't call method current_preset on an undefined value at /usr/share/perl5/vendor_perl/Slic3r/GUI/SkeinPanel.pm line 201


Version-Release number of selected component (if applicable):
9.10(a)


How reproducible:
each time


Steps to Reproduce on first machine:
1. loading a config.ini file
2.
3.

Steps to Reproduce on first machine:
1. loading a config.ini file
2. loading a stl file
3. slicing


Actual results:

in both cases slic3r scrach


Additional info:

New version 9.10.b is fully functional
An update from 9.10(a) to 9.10b should be a solution


Thank for help


LAurent_B (www.plateforme-c.org/‎)
Comment 1 Miro Hrončok 2013-10-18 06:32:01 EDT
I'm awere of this problem for some days now.

However, how didi you get the info about version 9.10(a)? In Fedora, we have 9.10b. And the problem is still present.
Comment 2 Fedora Update System 2013-10-18 07:54:28 EDT
slic3r-0.9.10b-4.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/slic3r-0.9.10b-4.fc19
Comment 3 Fedora Update System 2013-10-19 05:15:35 EDT
Package slic3r-0.9.10b-4.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing slic3r-0.9.10b-4.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-19495/slic3r-0.9.10b-4.fc19
then log in and leave karma (feedback).
Comment 4 Miro Hrončok 2013-10-20 11:44:59 EDT
LAurent_B: Could you please test the update and add karma if it fixes your issue? Thanks.
Comment 5 Fedora Update System 2013-10-22 00:57:51 EDT
slic3r-0.9.10b-4.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.