Bug 1020833 - bad requires: yum install openlmi*
bad requires: yum install openlmi*
Status: CLOSED DUPLICATE of bug 1019664
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: openlmi-providers (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Radek Novacek
qe-baseos-daemons
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-18 07:02 EDT by Petr Sklenar
Modified: 2016-11-30 19:32 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-21 09:58:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Sklenar 2013-10-18 07:02:27 EDT
Description of problem:
there is issue in requires of openlmi-indicationmanager-libs-devel

Version-Release number of selected component (if applicable):
openlmi-indicationmanager-libs-devel.x86_64 0:0.3.0-1.el7 

How reproducible:
always

Steps to Reproduce:
0. add latest repodata:
baseurl=http://download-01.eng.brq.redhat.com/pub/rhel/nightly/latest-RHEL-7/compose/Server/x86_64/os

# it should be RHEL-7.0-20131018.n.0
1. yum install openlmi*


Actual results:
[root@pes-guest-90 test]# yum install openlmi-indicationmanager-libs-devel
Loaded plugins: product-id, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Resolving Dependencies
--> Running transaction check
---> Package openlmi-indicationmanager-libs-devel.x86_64 0:0.3.0-1.el7 will be installed
--> Processing Dependency: openlmi-providers(x86-64) = 0.3.0-1.el7 for package: openlmi-indicationmanager-libs-devel-0.3.0-1.el7.x86_64
--> Finished Dependency Resolution
Error: Package: openlmi-indicationmanager-libs-devel-0.3.0-1.el7.x86_64 (beaker-Server-optional)
           Requires: openlmi-providers(x86-64) = 0.3.0-1.el7
           Installed: openlmi-providers-0.3.0-2.el7.x86_64 (@beaker-Server)
               openlmi-providers(x86-64) = 0.3.0-2.el7
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


Expected results:
I can do: "yum install openlmi*"

Additional info:
Comment 3 Radek Novacek 2013-10-21 02:46:41 EDT
This seems to be an issue with the repositories:

You're trying to install openlmi-indicationmanager-libs-devel.x86_64 0:0.3.0-1.el7, which requires openlmi-providers package. But there is already openlmi-providers-0.3.0-2 in the repo. But there is no openlmi-indicationmanager-libs-devel-0.3.0-2 in the optional repo.

It looks like the repo was not synced when you tried. There is correct package there now: http://download-01.eng.brq.redhat.com/pub/rhel/nightly/latest-RHEL-7/compose/Server-optional/x86_64/os/Packages/


Can you please retry it?
Comment 5 Radek Novacek 2013-10-21 09:58:39 EDT
This one is duplicate of bug 1019664.

*** This bug has been marked as a duplicate of bug 1019664 ***

Note You need to log in before you can comment on or make changes to this bug.