Bug 1020850 - Enable per client logging for gluster shares served by Samba
Enable per client logging for gluster shares served by Samba
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: samba (Show other bugs)
2.1
x86_64 Linux
high Severity medium
: ---
: RHGS 2.1.2
Assigned To: Poornima G
surabhi
: ZStream
Depends On: 1020848
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-18 07:32 EDT by Poornima G
Modified: 2015-05-13 12:29 EDT (History)
8 users (show)

See Also:
Fixed In Version: 3.4.0.44.1u2rhs
Doc Type: Bug Fix
Doc Text:
Previously, all the SAMBA clients having access to a specific Red Hat Storage volume would log messages in a single log file making it difficult to debug issues. With this fix, by default, a log file is created for every SAMBA client and the log file name will have the clients' internet name appended to it making it easy to identify.
Story Points: ---
Clone Of: 1020848
Environment:
Last Closed: 2014-02-25 02:55:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Poornima G 2013-10-18 07:32:32 EDT
+++ This bug was initially created as a clone of Bug #1020848 +++

Description of problem:
As of yet, all the samba clients mounting the gluster volume have a common log file, with this debugging becomes cumbersome.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:
Enable Vfs-gluster plugin of samba to support per client per volume logging.

Additional info:
Comment 4 Raghavendra Talur 2013-11-26 01:35:34 EST
patch posted for review at 
https://code.engineering.redhat.com/gerrit/#/c/14249/
Comment 5 surabhi 2013-12-12 01:05:27 EST
Tested per client per volume logging in gluster version :
samba-glusterfs-3.6.9-160.7.el6rhs.x86_64
glusterfs-3.4.0.47.1u2rhs-1.el6rhs.x86_64

Seperate log is getting created per volume but per client logging still can't be verified as it is showing : glusterfs-dis-rep.%M.log glusterfs-new-vol.%M.log.
To verify the per client logging we need new samba build with the fix.
Moving the bug back to assigned.
Comment 6 Vivek Agarwal 2013-12-13 03:54:56 EST
Removing it from Corbett per bug triage 12/13, will revive it for when the upstream samba patch gets merged.
Comment 7 Gowrishankar Rajaiyan 2013-12-13 04:14:37 EST
Patch in comment #4 for logs per volume has been tested and verified. However, complete verification can be done only with new samba build.
Comment 8 Poornima G 2013-12-24 06:38:40 EST
samba-3.6.9-167.8.el6rhs Has the fix for this issue.
Comment 9 surabhi 2013-12-24 06:46:43 EST
Verified the issue in following version:

glusterfs-libs-3.4.0.52rhs-1.el6rhs.x86_64
glusterfs-server-3.4.0.52rhs-1.el6rhs.x86_64
glusterfs-api-3.4.0.52rhs-1.el6rhs.x86_64
glusterfs-devel-3.4.0.52rhs-1.el6rhs.x86_64
glusterfs-3.4.0.52rhs-1.el6rhs.x86_64
glusterfs-fuse-3.4.0.52rhs-1.el6rhs.x86_64
glusterfs-debuginfo-3.4.0.52rhs-1.el6rhs.x86_64
glusterfs-geo-replication-3.4.0.52rhs-1.el6rhs.x86_64
glusterfs-rdma-3.4.0.52rhs-1.el6rhs.x86_64
samba-glusterfs-3.6.9-167.8.el6rhs.x86_64
glusterfs-api-devel-3.4.0.52rhs-1.el6rhs.x86_64

In /var/log/samba per volume per client logs are getting created.
Comment 10 Pavithra 2014-01-03 05:45:04 EST
Can you please review the doc text for technical accuracy?
Comment 11 Poornima G 2014-01-17 05:14:12 EST
The doc text looks fine.
Comment 13 errata-xmlrpc 2014-02-25 02:55:44 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html

Note You need to log in before you can comment on or make changes to this bug.