Bug 1020869 - Improve notifications
Improve notifications
Status: CLOSED WONTFIX
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Jan
Zuzana Krejčová
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-18 08:08 EDT by Zuzana Krejčová
Modified: 2016-07-31 21:09 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 16:07:27 EST
Type: Enhancement
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zuzana Krejčová 2013-10-18 08:08:20 EDT
Description of problem:
Right now, users are notified about various things via Uberfire notifications - small pop-up messages. These are quite unfortunate and I'm not sure if they can be improved.
It's a nice widget, but when you get an unexpected notification, it is gone too quick and you are unable to read the message. You might even miss it if you look away for a second. Or you're expecting it, you know what it says because you've seen it hundreds of times and it just blocks you from switching perspectives to continue your work.
It is only usable for very very short messages that the user expects and wants to see - which doesn't happen too often. After some time working with the product, I can honestly say these notifications seriously annoy me.

Perhaps we could have some kind of notification inbox/message tray that would be unobtrusive but easy to get to, where these notifications would stay until you dismiss them.

The idea is to have only that one way of getting notifications, not to have such inbox and the pop-up notifications at the same time.
Comment 2 Jan 2015-02-23 14:20:31 EST
See related BZ; the display time for this type of opoup notification has been raised by several seconds, to be able to read them.
IMO this does not constitute a problem, because if you already know them, they can be easily dismissed by hitting the 'X' in the top right corner.
Comment 3 Zuzana Krejčová 2015-02-24 02:57:31 EST
This is not exactly about raising the display time of a pop-up. Please see the description and comment 1. Raising display time from 2 seconds to 5 seconds, if I read that commit correctly, is not a solution to this.
Comment 4 Jan 2015-02-24 05:59:32 EST
My comment was pointing at the first part of your comment, i.e. "it is gone too quick and you are unable to read the message. You might even miss it if you look away for a second". The commit does solve this, as a temporary workaround for at least this part.

About whether the type of popup is annoying to you or not, I cannot say anything sensible, but this should be the object of a little more serious debate in a UX context, I cannot go into changing basic workbench functionality based on someone's personal preferences. In whatever case this should be tackled as an improvement.

Note You need to log in before you can comment on or make changes to this bug.