Bug 1020891 - disabling repository sets is not working
disabling repository sets is not working
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.0.2
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: Justin Sherrill
Garik Khachikyan
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-18 09:04 EDT by Ales Dujicek
Modified: 2015-01-04 17:00 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-24 13:08:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ales Dujicek 2013-10-18 09:04:13 EDT
Description of problem:

'product repository_set_disable' command does not disable repository set:

> product repository_set_disable --org testorg --name "Red Hat Enterprise Linux Server" --set_name "Red Hat Enterprise Linux 6 Server (RPMs)"
Repository Set [ Red Hat Enterprise Linux 6 Server (RPMs) ] disabled.

> product repository_sets --org testorg --name "Red Hat Enterprise Linux Server" -v
ID       : 168
Name     : Red Hat Enterprise Linux 6 Server (RPMs)
Enabled? : True

repository set is still enabled ^^

Version-Release number of selected component (if applicable):
katello-all-1.4.6-39.el6sat.noarch
katello-selinux-1.4.4-4.el6sat.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
katello-1.4.6-39.el6sat.noarch
signo-katello-0.0.22-2.el6sat.noarch
katello-configure-foreman-proxy-1.4.7-5.el6sat.noarch
katello-glue-candlepin-1.4.6-39.el6sat.noarch
katello-glue-pulp-1.4.6-39.el6sat.noarch
katello-cli-common-1.4.3-24.el6sat.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-configure-1.4.7-5.el6sat.noarch
katello-glue-elasticsearch-1.4.6-39.el6sat.noarch
katello-configure-foreman-1.4.7-5.el6sat.noarch
katello-foreman-all-1.4.6-39.el6sat.noarch
pulp-katello-plugins-0.2-1.el6sat.noarch
ruby193-rubygem-foreman-katello-engine-0.0.17-6.el6sat.noarch
ruby193-rubygem-katello-foreman-engine-0.0.11-3.el6sat.noarch
ruby193-rubygem-katello_api-0.0.3-4.el6sat.noarch
katello-common-1.4.6-39.el6sat.noarch
katello-cli-1.4.3-24.el6sat.noarch
katello-certs-tools-1.4.4-1.el6sat.noarch
katello-qpid-client-key-pair-1.0-1.noarch

How reproducible:
always

Steps to Reproduce:
1. import manifest
2. enable repository set
3. try to disable it
Comment 3 RHEL Product and Program Management 2013-10-23 18:44:50 EDT
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 4 Justin Sherrill 2013-10-24 14:01:39 EDT
https://github.com/Katello/katello/pull/3268
Comment 7 Og Maciel 2013-10-31 10:00:01 EDT
Verified by automation.
Comment 8 Bryan Kearney 2014-04-24 13:08:53 EDT
This was verified and delivered with MDP2. Closing it out.
Comment 9 Bryan Kearney 2014-04-24 13:10:31 EDT
This was delivered and verified with MDP2. Closing the bug.

Note You need to log in before you can comment on or make changes to this bug.