Bug 1020892 - Longer content of history variables dialog is over the nearby fields
Longer content of history variables dialog is over the nearby fields
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
high Severity medium
: ER6
: 6.0.0
Assigned To: Mauricio Salatino
Ivo Bek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-18 09:05 EDT by Ivo Bek
Modified: 2014-08-06 16:07 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:07:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Variable history dialog (30.94 KB, image/png)
2013-10-18 09:05 EDT, Ivo Bek
no flags Details

  None (edit)
Description Ivo Bek 2013-10-18 09:05:55 EDT
Created attachment 813769 [details]
Variable history dialog

Description of problem:

The attached screenshot explains the problem.
Comment 1 Mauricio Salatino 2013-11-22 04:23:31 EST
There is no way around this problem, because we don't have resizable popups. There are some plans to migrate these screens out of the popups so we can have a split perspective with the variable list and the details panels, like in tasks. 
Maybe it's a good time to do that but it could take some time, so I will check with Kris about this one.
Comment 2 Mauricio Salatino 2013-11-24 18:20:08 EST
I've added a tooltip that shows the full content of the old and new value for the variable. I'm also trimming the variable value if it has more than 20 chars, so if it is long the user will need to point the table row in order to see the tooltip with the full value:
Fixed in 6.0.x: http://github.com/droolsjbpm/jbpm-console-ng/commit/6cdcac446
Comment 3 Ivo Bek 2014-01-03 08:02:03 EST
Verified in BPMS 6.0.0.ER7

Filed another BZ 1048230 for the history variable window.
Comment 4 Ivo Bek 2014-03-18 08:24:31 EDT
It is not possible (yet) to test how the table looks and whether the content is over the nearby fields.

Note You need to log in before you can comment on or make changes to this bug.