Bug 102094 - (NET 3C59X) bug in 3c59x module kernel 2.6-test3?
(NET 3C59X) bug in 3c59x module kernel 2.6-test3?
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
1.0
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-11 05:34 EDT by Alin Osan
Modified: 2013-07-02 22:13 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-01 14:26:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alin Osan 2003-08-11 05:34:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030712

Description of problem:
The kernel 2.6-test3 has a very high packet lost rate using 3COM NIC (3c900B-TPO
[Etherlink XL TPO]). Here is what happens with ping:

PING 193.xxx.188.2 (193.xxx.188.2) 56(84) bytes of data.
ping: sendmsg: No buffer space available
ping: sendmsg: No buffer space available
ping: sendmsg: No buffer space available

new trial again:

root@ronnie root]# ping 193.xxx.188.2
PING 193.xxx.188.2 (193.231.188.2) 56(84) bytes of data.
From 193.xxx.188.240 icmp_seq=1 Destination Host Unreachable
From 193.xxx.188.240 icmp_seq=2 Destination Host Unreachable
From 193.xxx.188.240 icmp_seq=3 Destination Host Unreachable
64 bytes from 193.xxx.188.2: icmp_seq=4 ttl=64 time=20807 ms
64 bytes from 193.xxx.188.2: icmp_seq=5 ttl=64 time=19808 ms
64 bytes from 193.xxx.188.2: icmp_seq=6 ttl=64 time=18808 ms
64 bytes from 193.xxx.188.2: icmp_seq=7 ttl=64 time=17809 ms

The same 3COM NIC works perfect with kernel 2.4. I tested a Realtek 8139 card
and it works fine.


Version-Release number of selected component (if applicable):
kernel-2.6.0-0.test3.1.31

How reproducible:
Always

Steps to Reproduce:
1. ping any host
2. have a cold drink waiting for echo
3. 
    

Actual Results:  masive packets lost rate

Expected Results:  smooth connection

Additional info:
Comment 1 Mike A. Harris 2004-09-22 03:30:02 EDT
Could be related or unrelated, but I have a friend who has installed
Fedora Core 2, and is trying to connect to AOL with the "penggy"
AOL dialer app (I've packaged it in rpm format and built rpm
packages for him).  He connects to AOL and gets an IP address,
etc. no problem, however he's unable to do anything.

When he pings anywhere he gets the same error as above:

ping: sendmsg: No buffer space available
ping: sendmsg: No buffer space available
ping: sendmsg: No buffer space available

He's using a Realtek 8029 PCI card with Fedora Core 2/i386.  After
a bit of googling, it seems that this might be a network driver
problem, but it isn't clear or conclusive.  Google was more of
a runaround than a help.  Most things I found were people
experiencing similar problems and asking for help with no replies.

So not sure if my friend's problem is the same as this one, but
the ping errors are the same, so I thought I'd add this comment
in case it turns out to be helpful at all.
Comment 2 Dave Jones 2004-10-29 23:38:03 EDT
did this get fixed in current kernels ?
Comment 3 Alin Osan 2004-10-30 03:26:33 EDT
Yes, it did get fixed.

Note You need to log in before you can comment on or make changes to this bug.