Bug 102096 - Anaconda keeps parted/diskset open
Anaconda keeps parted/diskset open
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda (Show other bugs)
3.0
s390 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks: 97942
  Show dependency treegraph
 
Reported: 2003-08-11 07:37 EDT by Phil Knirsch
Modified: 2015-03-04 20:12 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-11 11:24:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Phil Knirsch 2003-08-11 07:37:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030709

Description of problem:
During installation anaconda only reads the diskset once and keeps it open. This
leads to problems on s390 and s390x when an LDL partition is found and the user
selects to do a low level format with dasdfmt.

One problem is that the device is still open and dasdfmt complains about that
fact (rightfully so, as we'll see later). This can (and currently is)
circumvented by using the -f option (force) with dasdftm which simply ignores
the fact that the device is open.

The problem that really hurts later on is that parted and anaconda sill belive
that there is 1 partition on the disk as the partitiontable is never reread
after dasdfmt.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Format a dasd with LDL
2. Reinstall system and select to reformat the LDL drive
3. Watch anaconda die later either during partitoning or formating

Actual Results:  Anaconda segfaults at some point later after repartitioning and
formating the drive but usually always before the actual installation begins.

Expected Results:  Anaconda shouldn't segfault. :-)

Additional info:

There are 3 possible solutions to this problem:

1 (easy): Don't allow to reformat LDL dasds. As they are currently also already
removed from the installation in general, that would be a reasonable fix.

2 (harder): After dasdfmt completely reread the diskset. This should be
possible, but i am not sure if there are any sideffects of doing so (see:
references to information in the diskset, e.g. partitions, sizes etc.).

3 (hardest): Modify parted and the python bindings to allow a reread of the disk
info. Not sure this makes any sense to be honest, as the same can be achived by
(2) in a much cleaner way.
Comment 1 Phil Knirsch 2003-08-11 07:41:10 EDT
For the whole LDL/CDL problem see:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=98504
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=98840

Read ya, Phil
Comment 2 Harald Hoyer 2003-08-12 11:21:04 EDT
most likely to be fixed in anaconda CVS now :)
Comment 3 Florian La Roche 2003-08-18 07:17:39 EDT
Reopening. Not yet fixed according to Harald. First patch works, but AFAIK
Jeremy wants to have a new one? Jeremy, is it clear on how the fix should
look like?

greetings,

Florian La Roche
Comment 4 Harald Hoyer 2003-08-18 12:05:38 EDT
it seems to be the loader, which does not close the fds ...
Comment 5 Jeremy Katz 2003-08-18 12:12:41 EDT
isUsableDasd wasn't closing the file.  Committed a fix.
Comment 6 Bill Nottingham 2004-10-11 11:24:29 EDT
Closing MODIFIED bugs as fixed. Please reopen if the problem perists.

Note You need to log in before you can comment on or make changes to this bug.