Bug 1020975 - node-certs 'repo' / feedless repos shouldn't show up under repo sync UI
node-certs 'repo' / feedless repos shouldn't show up under repo sync UI
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer (Show other bugs)
6.0.2
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Justin Sherrill
Og Maciel
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-18 12:00 EDT by Corey Welton
Modified: 2014-04-24 13:08 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-24 13:08:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (32.85 KB, image/png)
2013-10-18 12:02 EDT, Corey Welton
no flags Details

  None (edit)
Description Corey Welton 2013-10-18 12:00:36 EDT
Description of problem:
After creating certs for child node(s), a new node-certs repo shows up in the repo sync page.  This cannot/shouldn't be synced and thus shouldn't actually show up in UI.

Version-Release number of selected component (if applicable):

Satellite-6.0.2-RHEL-6-20131016.0

How reproducible:


Steps to Reproduce:
1.  Generate certs for child node(s).
2.  Content > Sync Management > Sync Status > Expand All
3.  Note the presence of "node-certs" repo; attempt to sync them.

Actual results:
Errors thrown.

Expected results:
These shouldn't show up in the UI.  Furthermore, according to mmccune, _no_ feedless repos should appear in the sync page, so the fix could probably be more than just a one-off for node-certs.

Additional info:
Comment 1 Corey Welton 2013-10-18 12:02:08 EDT
Created attachment 813832 [details]
screenshot
Comment 2 Mike McCune 2013-10-18 12:07:59 EDT
The bug is that for some reason the node-installer is setting up the node-certs repo with a feed of "http://localhost" which we really don't need since all the packages are being uploaded
Comment 4 Justin Sherrill 2013-10-18 17:14:56 EDT
https://github.com/Katello/node-installer/pull/7
Comment 5 Mike McCune 2013-10-21 23:44:39 EDT
this should be POST.  fixing
Comment 8 Og Maciel 2013-10-24 15:20:29 EDT
Verified:

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.8.25-1.el6sam.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.25-1.el6sam.noarch
* candlepin-tomcat6-0.8.25-1.el6sam.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* foreman-1.3.0-20.el6sat.noarch
* foreman-compute-1.3.0-20.el6sat.noarch
* foreman-libvirt-1.3.0-20.el6sat.noarch
* foreman-postgresql-1.3.0-20.el6sat.noarch
* foreman-proxy-1.3.0-3.el6sat.noarch
* katello-1.4.6-47.el6sat.noarch
* katello-all-1.4.6-47.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.4-1.el6sat.noarch
* katello-cli-1.4.3-27.el6sat.noarch
* katello-cli-common-1.4.3-27.el6sat.noarch
* katello-common-1.4.6-47.el6sat.noarch
* katello-configure-1.4.7-7.el6sat.noarch
* katello-configure-foreman-1.4.7-7.el6sat.noarch
* katello-foreman-all-1.4.6-47.el6sat.noarch
* katello-glue-candlepin-1.4.6-47.el6sat.noarch
* katello-glue-elasticsearch-1.4.6-47.el6sat.noarch
* katello-glue-pulp-1.4.6-47.el6sat.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-1.4.4-4.el6sat.noarch
* openldap-2.4.23-31.el6.x86_64
* pulp-katello-plugins-0.2-1.el6sat.noarch
* pulp-nodes-common-2.3.0-0.22.beta.el6sat.noarch
* pulp-nodes-parent-2.3.0-0.22.beta.el6sat.noarch
* pulp-puppet-plugins-2.3.0-0.22.beta.el6sat.noarch
* pulp-rpm-plugins-2.3.0-0.22.beta.el6sat.noarch
* pulp-selinux-2.3.0-0.22.beta.el6sat.noarch
* pulp-server-2.3.0-0.22.beta.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.2.2-2.el6sat.noarch
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.0.7-1.el6sat.noarch
* signo-0.0.23-2.el6sat.noarch
* signo-katello-0.0.23-2.el6sat.noarch
Comment 9 Bryan Kearney 2014-04-24 13:08:06 EDT
This was verified and delivered with MDP2. Closing it out.

Note You need to log in before you can comment on or make changes to this bug.