Bug 1021054 - centos wxpython installs but pycrust fails
centos wxpython installs but pycrust fails
Status: CLOSED NOTABUG
Product: Fedora EPEL
Classification: Fedora
Component: wxPython (Show other bugs)
el6
i386 Linux
unspecified Severity low
: ---
: ---
Assigned To: Marek Mahut
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-18 18:09 EDT by reb
Modified: 2014-12-04 19:53 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-04 19:32:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description reb 2013-10-18 18:09:03 EDT
Description of problem:

Installed wxPython-2.8.12.0-1.el6.i686 on CentOS 6.4 without error. At the command line when running pycrust get the following error:

Traceback (most recent call last):
  File "/usr/bin/pycrust", line 3, in <module>
    from wx.py.PyCrust import main
ImportError: No module named py.PyCrust

Version-Release number of selected component (if applicable):

wxPython-2.8.12.0-1.el6.i686

How reproducible:

every time

Steps to Reproduce:
1. install wxPython-2.8.12.0-1.el6.i686
2. try to run pycrust
3. fails with error above

Actual results:

fails with error

Expected results:

getting the crust from the py

Additional info:
Comment 1 Scott Talbert 2014-12-04 19:18:38 EST
Hi reb,

Are you still seeing this problem?  I just tried this on a freshly build CentOS 6.6 VM and it worked fine.
Comment 2 reb 2014-12-04 19:31:44 EST
(In reply to Scott Talbert from comment #1)
> Hi reb,
> 
> Are you still seeing this problem?  I just tried this on a freshly build
> CentOS 6.6 VM and it worked fine.

Wow, over a year later. Thanks.

I just tried it again and got the same error. I un/re-installed just now and tried it again and received same error. I'm upgraded to 6.6 as well.

I've long since lost interest so I remain unintersted. Thanks.
Comment 3 Scott Talbert 2014-12-04 19:53:08 EST
Sorry about the delay.  I just became co-maintainer.  I noticed you are using the i686 package - I wonder if maybe there is some problem with that version.  Anyway, if you're not interested, I won't pursue further.

Note You need to log in before you can comment on or make changes to this bug.