Bug 1021089 - quota: performance degradation, limit-set on 64000 directories is taking long time
quota: performance degradation, limit-set on 64000 directories is taking long...
Status: CLOSED DUPLICATE of bug 977544
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
2.1
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Krutika Dhananjay
Sudhir D
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-19 05:47 EDT by Saurabh
Modified: 2016-01-19 01:13 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-23 09:44:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Saurabh 2013-10-19 05:47:19 EDT
Description of problem:
I have been trying to set quota limits on 64000 directories and since last 14-15 hours it has only finished somewhere around 7200 directories having limits set.

When I started the test, the limit set on directories was quite fast but now it is quite slow. 


Version-Release number of selected component (if applicable):
gluster-3.4.0.35rhs

How reproducible:
performance degradation happen to be seen second time

Steps to Reproduce:
1. mount volume over nfs
2. create 64000 directories
3. set quota limits on 64000 directories

Actual results:
it has just finished 7200 directories in last 14-15 hours

Expected results:
this performance is very slow, as per the expectation 1/4 sec should be taken to set limit and no eventual degradation in performance.

Additional info:
I having 4 VM setup on a hyper visor, dedicated just for quota related test efforts
each VM has 8GB RAM and 4CPUs.

Note You need to log in before you can comment on or make changes to this bug.