Bug 102111 - See bug id 101678 - Setting up link to libtcl.so does not solve my problem.Still cannot install db3x*.rpm, need libtcl.so.0.
See bug id 101678 - Setting up link to libtcl.so does not solve my problem.St...
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: tcltk (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
Bill Huang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-11 11:02 EDT by Scott Gravning
Modified: 2007-04-18 12:56 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-18 02:46:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Gravning 2003-08-11 11:02:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
Trying to install db3x*.rpm, failed dependency libtcl.so.0.
Library is missing in RHL 9.0, exists in RHL 7.2  Previous Bugzilla solution 
is to create a link from libtcl.so to libtcl.so.0, this is not working on my 
system.  Still receive Failed dependency error.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Run command:  rpm -ihv db3x*.rpm
2.3.
    

Actual Results:  Receive Failed Dependency error, missing libtcl.so.0


Expected Results:  Rpm should have installed.

Additional info:

I have no workaround, need this to work asap.  
Thank you.
Comment 1 Jens Petersen 2003-09-02 01:59:45 EDT
Did you run "ldconfig" after making the symlink?

What error are you seeing?
Comment 2 Scott Gravning 2003-09-02 08:58:23 EDT
No, I did not run Idconfig after making the symlink.  Sorry but I am not 
familiar with Idconfig, is it necessary to run it?  When I run rpm -Uhv 
db3x*.rpm, I get this:   error: Failed dependencies: libtcl.so.0 is needed by 
db3x-3.2.9-4

So far, the Red Hat phone support staff has not been able to solve this. Any 
is greatly appreciated.  
Comment 3 Jens Petersen 2003-09-03 04:38:00 EDT
Yes, I think so.

(The program name is "LDCONFIG" in lowercase of course, not "IDCONFIG" btw.)
Comment 4 Jens Petersen 2003-09-18 02:46:53 EDT
Another solution is to take the db3x source rpm (srpm) and rebuild it
on your RHL 9 installation.
Comment 5 Scott Gravning 2003-09-18 08:37:24 EDT
RHL 9.0 uses compat-db rpm to replace db3x, I installed it and the problem was 
resolved.

Note You need to log in before you can comment on or make changes to this bug.