Bug 1021127 - AttributeError: 'NoneType' object has no attribute 'type'
AttributeError: 'NoneType' object has no attribute 'type'
Status: CLOSED DUPLICATE of bug 864257
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:e4bd50aa57ff8977679e440c87d...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-19 12:39 EDT by Martin Milata
Modified: 2013-10-21 08:21 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-21 08:21:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (690.95 KB, text/plain)
2013-10-19 12:39 EDT, Martin Milata
no flags Details
File: anaconda.log (45.12 KB, text/plain)
2013-10-19 12:40 EDT, Martin Milata
no flags Details
File: environ (460 bytes, text/plain)
2013-10-19 12:40 EDT, Martin Milata
no flags Details
File: lsblk_output (1.98 KB, text/plain)
2013-10-19 12:40 EDT, Martin Milata
no flags Details
File: nmcli_dev_list (7.41 KB, text/plain)
2013-10-19 12:40 EDT, Martin Milata
no flags Details
File: os_info (179 bytes, text/plain)
2013-10-19 12:40 EDT, Martin Milata
no flags Details
File: program.log (31.08 KB, text/plain)
2013-10-19 12:40 EDT, Martin Milata
no flags Details
File: storage.log (165.30 KB, text/plain)
2013-10-19 12:40 EDT, Martin Milata
no flags Details
File: syslog (125.25 KB, text/plain)
2013-10-19 12:40 EDT, Martin Milata
no flags Details
File: ifcfg.log (822 bytes, text/plain)
2013-10-19 12:40 EDT, Martin Milata
no flags Details
File: packaging.log (177.34 KB, text/plain)
2013-10-19 12:40 EDT, Martin Milata
no flags Details

  None (edit)
Description Martin Milata 2013-10-19 12:39:52 EDT
Version-Release number of selected component:
anaconda-19.30.13-1

The following was filed automatically by anaconda:
anaconda 19.30.13-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 297, in _removeDevice
    if dev.partedPartition.type == parted.PARTITION_EXTENDED and \
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 344, in registerAction
    self._removeDevice(action.device)
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 1179, in destroyDevice
    self.devicetree.registerAction(action)
  File "/usr/lib/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2024, in _destroy_device
    self.__storage.destroyDevice(device)
  File "/usr/lib/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2075, in _destroy_device
    self._destroy_device(parent)
  File "/usr/lib/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2146, in on_remove_clicked
    self._destroy_device(dev)
AttributeError: 'NoneType' object has no attribute 'type'

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019\x20i386 quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.i686
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19
Comment 1 Martin Milata 2013-10-19 12:39:59 EDT
Created attachment 814053 [details]
File: anaconda-tb
Comment 2 Martin Milata 2013-10-19 12:40:04 EDT
Created attachment 814054 [details]
File: anaconda.log
Comment 3 Martin Milata 2013-10-19 12:40:11 EDT
Created attachment 814055 [details]
File: environ
Comment 4 Martin Milata 2013-10-19 12:40:15 EDT
Created attachment 814056 [details]
File: lsblk_output
Comment 5 Martin Milata 2013-10-19 12:40:19 EDT
Created attachment 814057 [details]
File: nmcli_dev_list
Comment 6 Martin Milata 2013-10-19 12:40:23 EDT
Created attachment 814058 [details]
File: os_info
Comment 7 Martin Milata 2013-10-19 12:40:28 EDT
Created attachment 814059 [details]
File: program.log
Comment 8 Martin Milata 2013-10-19 12:40:32 EDT
Created attachment 814060 [details]
File: storage.log
Comment 9 Martin Milata 2013-10-19 12:40:36 EDT
Created attachment 814061 [details]
File: syslog
Comment 10 Martin Milata 2013-10-19 12:40:41 EDT
Created attachment 814062 [details]
File: ifcfg.log
Comment 11 Martin Milata 2013-10-19 12:40:45 EDT
Created attachment 814063 [details]
File: packaging.log
Comment 12 Martin Milata 2013-10-21 08:21:17 EDT

*** This bug has been marked as a duplicate of bug 864257 ***

Note You need to log in before you can comment on or make changes to this bug.