Bug 1021259 - Redirecting Loop when accessing foreman from katello using SSO
Redirecting Loop when accessing foreman from katello using SSO
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer (Show other bugs)
Nightly
x86_64 Linux
unspecified Severity high (vote)
: Unspecified
: 6.0
Assigned To: Katello Bug Bin
Katello QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-20 15:56 EDT by mshurik
Modified: 2014-09-18 11:35 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 15:17:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mshurik 2013-10-20 15:56:08 EDT
Description of problem:
after installing katello-foreman-all and ran katello-configure I am unable to access foreman URL from Katello WEB UI. Getting page display that saying redirecting loop

Version-Release number of selected component (if applicable):
nightly build of katello 

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 mshurik 2013-10-20 16:54:13 EDT
this is info from foreman log

Started GET "/foreman/?username=admin&username=admin" for MY IP at 2013-10-20 14:49:48 -0600
Processing by DashboardController#index as HTML
  Parameters: {"username"=>"admin"}
  Rendered text template (0.0ms)
Filter chain halted as :require_login rendered or redirected
Completed 401 Unauthorized in 1ms (Views: 0.3ms | ActiveRecord: 0.0ms)
Processing by DashboardController#index as HTML
  Parameters: {"username"=>"admin"}
SSO failed, falling back to login form
Redirected to https://localhost.localdomain/signo?return_url=https://localhost.localdomain/foreman/?username=admin&username=admin
Filter chain halted as :require_login rendered or redirected
Completed 302 Found in 1ms (ActiveRecord: 0.0ms
Comment 2 Mike McCune 2013-10-23 18:04:34 EDT
Did you use a fully qualified hostname when installing Katello & Foreman?
Comment 3 mshurik 2013-10-23 19:14:18 EDT
Thanks Mike for replying to me. I do have DNS set up for my host and also have set /etc/hosts file. The host name I have is katman.ucdenver.pvt and the short name is katman. The setting in /etc/katello/katello.yml is saying for both katello and foreman is https://katman/katello and https://katman/foreman and for SSO is https://katman/signo

I just want integrate katello and foreman on the same box using SSO.
Comment 4 Mike McCune 2013-10-28 21:59:41 EDT
yeah, try using the FQDN for all configuration values

if you want to start over you can remove katello and foreman with:

https://raw.github.com/mccun934/katello-misc/master/scripts/katello_remove.sh

and try again.

or just re-provision the host you are installing on.
Comment 5 mshurik 2013-10-28 22:09:36 EDT
Thank you Mike,

I have done this as well. I have reinstall everything using FQDN and still having same issue. I have install katello-foreman-all and then ran katello-configure --user-pass=admin.I did not see any errors during installation but than again

1. login successful https://katman.ucdenver.pvt/katello
2. click on foreman link in right top corner 
3. did redirect me signo login page 
4. when entering my credentials it give a page "redirect loop"
Comment 6 Bryan Kearney 2014-01-21 14:06:58 EST
Moving to Sat6 to be tracked there. Upstream bugs are moving to redmine.
Comment 7 RHEL Product and Program Management 2014-01-21 14:18:49 EST
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 9 Bryan Kearney 2014-01-21 15:17:04 EST
signo is still removed from katello, closing this out.

Note You need to log in before you can comment on or make changes to this bug.