Bug 1021304 - Deployments table ordering
Deployments table ordering
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: DT Governance (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity unspecified
: ER7
: 6.0.0
Assigned To: Eric Wittmann
Stefan Bunciak
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-20 23:17 EDT by Catherine Robson
Modified: 2014-03-05 10:46 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker DTGOV-93 Major Closed Sorting in Deployments UI and Task Inbox 2014-03-05 10:46:13 EST

  None (edit)
Description Catherine Robson 2013-10-20 23:17:13 EDT
Description of problem:
When a user is looking at the Deployments list in the DT Gov console, the ordering ends up off because of versions (1.0.1 and then 1.0.11 due to alphabetical)  

Suggested resolution:
Sort by date/time deployed instead with the latest deployed item at the top of the table.
Comment 2 JBoss JIRA Server 2013-10-22 12:36:22 EDT
Eric Wittmann <eric.wittmann@redhat.com> updated the status of jira DTGOV-93 to Resolved
Comment 3 JBoss JIRA Server 2013-10-22 12:36:28 EDT
Eric Wittmann <eric.wittmann@redhat.com> updated the status of jira DTGOV-93 to Closed
Comment 4 Eric Wittmann 2013-10-23 08:12:03 EDT
Solved this by making the table columns sortable (when appropriate).  I've done this for the following pages:

* Deployments listing
* Task Inbox
* S-RAMP Artifacts listing

The default sort order has been chosen as appropriate for each page.  For example, the default sort for Deployments is now Initiated On:descending.
Comment 5 Stefan Bunciak 2014-01-06 05:22:29 EST
Verified in FSW 6.0.0.ER8
Comment 6 JBoss JIRA Server 2014-03-05 10:40:41 EST
Eric Wittmann <eric.wittmann@redhat.com> updated the status of jira DTGOV-93 to Reopened
Comment 7 JBoss JIRA Server 2014-03-05 10:46:18 EST
Eric Wittmann <eric.wittmann@redhat.com> updated the status of jira DTGOV-93 to Closed

Note You need to log in before you can comment on or make changes to this bug.