Bug 1021342 - Aggregation of corrections for F20 Release Notes
Aggregation of corrections for F20 Release Notes
Status: CLOSED CURRENTRELEASE
Product: Fedora Documentation
Classification: Fedora
Component: release-notes (Show other bugs)
devel
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Release Notes Tracker
Fedora Docs QA
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-21 02:47 EDT by Pete Travis
Modified: 2014-01-18 17:29 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-18 17:29:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A patch to fix typos (3.32 KB, patch)
2013-10-23 03:52 EDT, Yuri Chornoivan
no flags Details | Diff
Fix typo patch (902 bytes, patch)
2013-11-29 23:30 EST, TianShixiong
no flags Details | Diff

  None (edit)
Description Pete Travis 2013-10-21 02:47:07 EDT
There are surely some typographical corrections and such that need to be made to the Release Notes. It would make things easier to track them in a single bug, so please report problems found here.
Comment 1 Pete Travis 2013-10-21 02:48:53 EDT
from tiansworld via trans:
In architecture section,
"ARM in Fedora is all grown up! With the release of Fedora 20 are is considered a primary architecture meaning that it receives the same amount of attention that the x86 and x86-64 releases get..."
I think "are" before is, should be arm. It's a typo.
Comment 2 Leslie Satenstein 2013-10-21 08:02:54 EDT
What is the Beta Release? 

The beta release is the last important milestone before the release of Fedora 20. A Beta release is code-complete and bears a very strong resemblance to the third and final release. Only critical bug fixes will be pushed as updates up to the general release of Fedora 20. The final release of Fedora 20 is expected in early December. 

If you do not as yet have a copy, here is where you go to fetch one.


=======
If I click on here, I do not get the final release of Fedora 20 I get a list of candidates.

Revise to
======
The beta release is the last important milestone before the release of Fedora 20. A Beta release is code-complete and bears a very strong resemblance to the third and final release. Only critical bug fixes will be pushed as updates up to the general release of Fedora 20. If you do not as yet have a candidate copy, here is where you go to fetch one.

The final release of Fedora 20 is expected in early December.
Comment 3 Leslie Satenstein 2013-10-21 08:08:54 EDT
10 Years of Fedora

The Fedora 20 release coincides nicely with the 10th anniversary of Fedora. The first Fedora release (then called Fedora Core 1) came out on November 6, 2003. 
Since then, the Fedora Project has become an active and vibrant community that produces nearly a dozen "spins" (A spin is a specially assembled version of Fedora. Refer to the Spin topic below ) that are tailor made for desktop users, hardware design, gaming, musicians, artists, and early classroom environments. 

=====
For non Fedora users or first time readers, it is good idea to explain what constitutes a spin. I would add the sentence to refer to the in the lower section that explains spins.
======
Comment 4 Leslie Satenstein 2013-10-21 08:10:46 EDT
NetworkManager Improvements

NetworkManager is getting several improvements in Fedora 20 that will be welcome additions for power users and system administrators. 
Users will now be able to add, edit, delete, activate, and de-activate network connections via the nmcli command line tool, which will make life much easier for non-desktop uses of Fedora. 

=====
The word now is superflous.I would drop the word.
=====

NetworkManager Improvements

NetworkManager is getting several improvements in Fedora 20 that will be welcome additions for power users and system administrators. 
Users will be able to add, edit, delete, activate, and de-activate network connections via the nmcli command line tool, which will make life much easier for non-desktop uses of Fedora.
Comment 5 Leslie Satenstein 2013-10-21 08:13:39 EDT
No Default Sendmail, Syslog
Fedora 20 removes some services that many users find unnecessary, though (of course) they will remain available as installable packages for users who might need them. 
The systemd journal now takes the place as the default logging solution, having been tested and able to manage persistent logging in place of syslog. 

=========
Consider
replacing 
now takes the place
with 
assumes
=========
The systemd journal assumes the role as the default logging solution, having been tested and able to manage persistent logging in place of syslog.
Comment 6 Leslie Satenstein 2013-10-21 08:16:08 EDT
OS Installer Support for LVM Thin Provisioning 
LVM has introduced thin provisioning technology, which provides greatly improved snapshot functionality in addition to thin provisioning capability. This change will make it possible to configure thin provisioning during OS installation. 


=====
revision
Please add lvm  as shown below so that the "This" refers to lvm and not the “improved snapshot functionality” or do you mean both changes. In that latter case put These changes will make it possible to.....
=====
 This lvm change will make it possible to configure thin provisioning during OS installation.
Comment 7 Leslie Satenstein 2013-10-21 08:28:43 EDT
VM Snapshot UI with virt-manager 

This change will make taking VM snapshots much easier. qemu and libvirt have all the major pieces in place for performing safe VM snapshots/checkpoints, however there isn't any simple discoverable UI. This feature will track adding that UI to virt-manager, and any other virt stack bits that need to be fixed/improved. This includes adding functionality to libvirt to support deleting and re-basing to external snapshots. 

=====
Is it a change or a new feature? 
I have not had occasion to use virt-manager. As written, the feature is assumed to have been always present, but is an improvement. Is it a change or a new feature? 
=======
Regarding the words that follow "This"  My comments follow.

"This change will.... " is ok by my public school grammmar.
"This feature will...." is ok by my public school grammar.
but
"This includes adding...   what is the word to add between "This and includes"?
 
======
Comment 8 Leslie Satenstein 2013-10-21 08:31:07 EDT
Under Developer Goodies.

A formatting comment only.

Should the paragraphs containing a brief description of Developer Goodies be indented?  The list falls under the above title.
Comment 9 Leslie Satenstein 2013-10-21 08:32:59 EDT
Note on performance 
Fedora development releases use a kernel with extra debug information to help us understand and resolve issues faster; however, this can have a significant impact on performance. Refer to the kernel debug strategy for more details. You can boot with slub_debug=- or use the kernel from nodebug repository to disable the extra debug info.

======
Replace “with extra” with the word “containing extra”.  The debug information is not next or beside the kernel, it is within the kernel.
======
Comment 10 Leslie Satenstein 2013-10-21 08:37:24 EDT
 Issues and Details 
Heisenbug Alpha is a testing release. To report issues encountered during testing, contact the Fedora QA team via the test mailing list or in #fedora-qa on freenode. 
As testing progresses, common issues are tracked at https://fedoraproject.org/wiki/Common_F20_bugs 
For tips on reporting a bug effectively, read http://fedoraproject.org/wiki/How_to_file_a_bug_report . 

=====
Ḑon't you mean Heisenburg Beta. We are well past the alpha stage. I would suggest the amendment below.
====
Heisenbug or Heisenburg

Heisenburg pre-release candidates are for testing functionality prior to the issuing of the final release.
Comment 11 Eric Christensen 2013-10-21 10:13:43 EDT
Leslie,
It's great you have all these questions but this is *not* the place to be discussing them.  You should open separate bugs, with patches, preferably, against the Release Notes.  This bug is *only* for small, typographical errors that translators might run into.

Thanks
Comment 12 Pete Travis 2013-10-21 10:44:26 EDT
Leslie:
At a glance, it looks like all of the amendments you are proposing are based on content in the Alpha Release Announcement. The announcement is *different* from the release notes; none of these complaints apply. As we discussed on the mailing list, the announcement is a collaborative effort on a wiki page, not a published guide with an applicable bugzilla component.
Comment 13 Leslie Satenstein 2013-10-22 22:42:53 EDT
Hi Pete and Eric.

I may post in the wrong place but please note well. I clicked on the Pete Travis email on the day I received it and it had a text which said to go "here" to post changes. I clicked on the "here" link.  Later I received an email from Eric (saying it was the wrong place to post. But I clicked on the provided link and sent to my libreoffice markup document.

I may make things difficult, and appear badly in your eyes, but it is not my intention. I like professional technical writing, and when I worked in a shop that specialized in documentation, word count was important, as well as precision. We had to write for machine (google, or other) translator software. 

It was drilled into me to scrutinize the grammar.  

I have a 12 hour day, been doing it for years, and therefore, I cannot assist in the IRC chats, or whatever. I relax by reading the posted messages or minutes of meetings, and I am grateful to Pete for them.

But what I posted, if you look at the "nit-picking" as some would call it, it is to make the "foreign reader" who is mentally translating the text, follow. Slang has a bad habit of creeping in. 

As well, it is to point out to the editors, that beyond the verification of the links and the accuracy, that the presentation is well written is one part, but when a preceding sentence has two or more subjects, if the next sentence begins with "this", then the this must be qualified. 

If you would like more of my nit-picking, I will work my fingers to the bone if someone could email me draft texts along with a must complete by date.
 
I have experience with POs and while they are great for translating individual sentences, they are against clarity for other languages. I live in French Quebec, and have a Spanish wife, so a) my French is good enough to catch errors, but not good enough to be efficient at writing succinctly. Similarly for Spanish.

Please email me at my address which you have on file. if you do not have it, it is lsatenstein at yahoo point com .  Sorry to respond to you gentlemen via bugzilla.
Comment 14 Yuri Chornoivan 2013-10-23 03:52:51 EDT
Created attachment 815265 [details]
A patch to fix typos

Just a patch to fix three issues with spacing and a period.
Comment 15 Pete Travis 2013-10-30 01:33:16 EDT
(In reply to Pete Travis from comment #1)
> from tiansworld via trans:
> In architecture section,
> "ARM in Fedora is all grown up! With the release of Fedora 20 are is
> considered a primary architecture meaning that it receives the same amount
> of attention that the x86 and x86-64 releases get..."
> I think "are" before is, should be arm. It's a typo.

commit f676cd0eb993d5252caa62bf0bd318b3938cf18d
Author: Jérôme Fenal <jfenal@free.fr>
Date:   Tue Oct 22 10:44:06 2013 +0200

    Fix typo in ARM

Thanks Jérôme!
Comment 16 Pete Travis 2013-10-30 23:27:55 EDT
(In reply to Yuri Chornoivan from comment #14)
> Created attachment 815265 [details]
> A patch to fix typos
> 
> Just a patch to fix three issues with spacing and a period.

Patch applied, thanks Yuri!

https://git.fedorahosted.org/cgit/docs/release-notes.git/commit/?id=74a46cd7eaf3e498f3d7d0fd3291fd020c456fd7
Comment 17 TianShixiong 2013-10-30 23:57:11 EDT
In newly updated Filesystem section, there is a typo.
...devices and populating thier filesystems from a recent backup.

thier should be their.

BTW, I would like to fix it by submitting a patch. But I still don't know how to do it. So please fix it yourself. :D
Comment 18 Pete Travis 2013-10-31 00:11:49 EDT
Fixed now, thanks.

I like to use git for quick-and-easy patches. Something like:

$ git clone ssh://git.fedorahosted.org/git/docs/release-notes.git # or pull
$ cd release-notes
$ git branch bz1021342;git checkout bz1021342 # create a disposable branch for the patch
$ vi en-US/Filesystems.xml #fix the error
$ git commit en-US/Filesystems.xml -m "fixing some idiot's typo" 
$ git format-patch master # one patch file created per commit
$ firefox https://bugzilla.redhat.com/show_bug.cgi?id=1021342 # share your patch
$ git checkout master; git branch -D bz1021342 # destroy the branch, you're done with it

Feel free to pop in to #fedora-docs for a more interactive discussion :)
Comment 19 TianShixiong 2013-10-31 01:00:42 EDT
Thanks Pete, the procedure you wrote is very clear. I will try it at next time.
Comment 20 TianShixiong 2013-11-26 09:49:42 EST
commit 21461e19f226066f5e53592d0e0bdfdaf13a7f94
Author: Tiansworld <tiansworld@fedoraproject.org>
Date:   Tue Nov 26 22:36:11 2013 +0800

    Fixing a small typo, added a space between ControlPort and the URL
Comment 21 Pete Travis 2013-11-29 20:30:01 EST
(In reply to TianShixiong from comment #20)
> commit 21461e19f226066f5e53592d0e0bdfdaf13a7f94
> Author: Tiansworld <tiansworld@fedoraproject.org>
> Date:   Tue Nov 26 22:36:11 2013 +0800
> 
>     Fixing a small typo, added a space between ControlPort and the URL

Fix applied. You forgot to push/attach your patch, Tian :)
Comment 22 TianShixiong 2013-11-29 23:18:59 EST
(In reply to Pete Travis from comment #21)
> (In reply to TianShixiong from comment #20)
> > commit 21461e19f226066f5e53592d0e0bdfdaf13a7f94
> > Author: Tiansworld <tiansworld@fedoraproject.org>
> > Date:   Tue Nov 26 22:36:11 2013 +0800
> > 
> >     Fixing a small typo, added a space between ControlPort and the URL
> 
> Fix applied. You forgot to push/attach your patch, Tian :)

Is it ok now? I've deleted the patch branch already.

I thought that I should make a push, but there is no "push" according to your procedure, so I ignored it. 
Anyway, it's the first time to submit something to a public git, caution should be taken. 

I will find some info on how to attach diff info, which Yuri Chornoivan did in this bug report.
Comment 23 Pete Travis 2013-11-29 23:21:38 EST
(In reply to TianShixiong from comment #22)
> 
> Is it ok now? I've deleted the patch branch already.
> 
> I thought that I should make a push, but there is no "push" according to
> your procedure, so I ignored it. 
> Anyway, it's the first time to submit something to a public git, caution
> should be taken. 
> 
> I will find some info on how to attach diff info, which Yuri Chornoivan did
> in this bug report.

I found the problem easily enough from your description, so no worries. The only part you missed was that `git format-patch ...` creates some .patch files in the working directory that you can then share via email or bz.
Comment 24 TianShixiong 2013-11-29 23:30:12 EST
Created attachment 830834 [details]
Fix typo patch
Comment 25 TianShixiong 2013-11-29 23:39:11 EST
> I found the problem easily enough from your description, so no worries. The
> only part you missed was that `git format-patch ...` creates some .patch
> files in the working directory that you can then share via email or bz.

I did that, but didn't know it would generate a patch file. Now it's attached. :)

Do I still need 'git push' after 'checkout'?
Comment 26 Pete Travis 2013-11-30 00:11:45 EST
(In reply to TianShixiong from comment #25)
> > I found the problem easily enough from your description, so no worries. The
> > only part you missed was that `git format-patch ...` creates some .patch
> > files in the working directory that you can then share via email or bz.
> 
> I did that, but didn't know it would generate a patch file. Now it's
> attached. :)
> 
> Do I still need 'git push' after 'checkout'?

There's no need to `git push` with this method; whoever accepts the patch can do that part for you. However, members of the "docs-writers" FAS group (which I believe you are) can skip the branch-patch sequence, commit directly to the source repo and `git push` their commit.  Either way is fine, that's up to you.

Whether you commit directly or submit patches, it is a good idea to communicate with the others working on the guide so the work doesn't overlap, strings can get repushed to tx, etc.
Comment 27 TianShixiong 2013-11-30 00:21:50 EST
> There's no need to `git push` with this method; whoever accepts the patch
> can do that part for you. However, members of the "docs-writers" FAS group
> (which I believe you are) can skip the branch-patch sequence, commit
> directly to the source repo and `git push` their commit.  Either way is
> fine, that's up to you.
> 
> Whether you commit directly or submit patches, it is a good idea to
> communicate with the others working on the guide so the work doesn't
> overlap, strings can get repushed to tx, etc.

Nothing more to say, thank you Pete.
Comment 28 Joshua Allen Holm 2013-12-05 11:50:40 EST
The link to "Fedora 20 Features" in section "1.2. Overview" still points to the page for Fedora 19's features. In the same section, the link that has the text "http://fedoraproject.org/wiki/Releases/20/FeatureList" also still points to Fedora 19's features (The text for the link was changed to 20, but not the link itself). It looks like FeatureList was superseded by ChangeSet on the wiki, so I assume the correct link should actually be http://fedoraproject.org/wiki/Releases/20/ChangeSet but I'm not 100% sure.

In section "1.5.1. Providing Feedback on Fedora Software" the link to "Common F20 Bugs" points to the common bugs page for Fedora 19.

Section "4.1.2. Developer Assistant" makes mention of "documentation in a devassist-docs package," which, as far as I can tell, does not exist. (yum list devassist* turns up nothing but devassistant itself).
Comment 29 Pete Travis 2013-12-06 11:02:03 EST
Good catch, Joshua! I've corrected those entries.
Comment 30 Pete Travis 2014-01-18 17:29:34 EST
Changes applied and published, thanks everyone!

Note You need to log in before you can comment on or make changes to this bug.