Bug 1021367 - when you want to browse files without nautilus installed, thunar is not lunched
when you want to browse files without nautilus installed, thunar is not lunched
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: blueman (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Juan Manuel Rodriguez
Fedora Extras Quality Assurance
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-21 03:40 EDT by Jan Hutař
Modified: 2013-12-10 03:17 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-09 19:02:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2013-10-21 03:40:14 EDT
Description of problem:
I have XFce desktop and do not have nautilus installed. Thunar handles files browsing as well (there seems to be bugs but basically it works).


Version-Release number of selected component (if applicable):
blueman-1.23-6.fc19.x86_64


How reproducible:
always


Steps to Reproduce:
1. Setup new blueetooth device for browsing it's files
2. Right-click blueman-applet and select "Browse Files on Device"
3. Select device and massage saying "You do not have 'nautilus' appears"


Actual results:
I have this but I have not configured it:

$ grep -r nautilus .config/gconf/apps/blueman/
.config/gconf/apps/blueman/transfer/%gconf.xml:		<stringvalue>nautilus --browser obex://[%d]</stringvalue>

And when I do not have nautilus installed I have not found way in Blueman GUI how to configure this.


Expected results:
Should work out of the box


Additional info:
This fixed problem for me although I do not know if it is a correct solution from your point of view:

# diff -u /usr/bin/blueman-browse{.ORIG,}
--- /usr/bin/blueman-browse.ORIG	2013-10-21 09:25:51.869107418 +0200
+++ /usr/bin/blueman-browse	2013-10-21 09:26:26.141949747 +0200
@@ -63,9 +63,9 @@
 		conf = Config("transfer")
 		if conf.props.browse_command == None:
 			conf.props.browse_command = DEF_BROWSE_COMMAND
-			if "nautilus" in DEF_BROWSE_COMMAND:
-				if not have("nautilus"):
-					conf.props.browse_command = "thunar obex://[%d]"
+		if "nautilus" in DEF_BROWSE_COMMAND:
+			if not have("nautilus"):
+				conf.props.browse_command = "thunar obex://[%d]"
 		
 		cmd = conf.props.browse_command.replace("%d", addr)
 		args = cmd.split(" ")
Comment 1 Juan Manuel Rodriguez 2013-12-09 19:02:13 EST
Hi Jan, 

I'm sorry for the delay with answering the bug report. Thanks a lot for the patch! I've filed a bug upstream with the patch. 

https://github.com/cschramm/blueman/issues/22

Blueman has been retired from Fedora, as it doesn't support Bluez. Development has recently restarted under new management, so here's hoping I can repackage it once it gets Bluez5 support. 

Sorry for the inconvenience!
Comment 2 Jan Hutař 2013-12-10 03:17:54 EST
No problem and thanks for the explanation.

Note You need to log in before you can comment on or make changes to this bug.