Bug 102140 - Not able to Install with Suptertrak SX6000
Not able to Install with Suptertrak SX6000
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2003-08-11 13:54 EDT by Homer Parker
Modified: 2007-04-18 12:56 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-09-30 11:41:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Homer Parker 2003-08-11 13:54:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021227

Description of problem:
Fresh install of RedHat 9 and I'm not able to install to the RAID on the SX6000.
Going to the console on F2, running lsmod shows i2o_block and i2o_core, but not
i2o_pci. Trying to insmod i2o_pci doesn't work. I also tried to rmmod the two
that were installed and insmod i2o_pci first, but then I couldn't get any of
them to insmod. I have tried with both a bios setting of Other and Linux. I
installed to another drive connected to the onboard IDE controller, and was able
to fdisk the RAID under /dev/i2o/hda. Even after that, tried a fresh install and
the RAID does not show up in Disk Druid.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Try to install RH 9 on a RAID controlled by a SX6000

Expected Results:  Able to install to the RAID

Additional info:
Comment 1 Bruno Vernay 2003-10-31 04:45:02 EST
You can use the driver provided by Promise for RH9. it creates a "disk driver"
that you can load with "linux dd" at install boot prompt.
But I couldn't compile an up to date kernel : the I2O fails !
Comment 2 Homer Parker 2003-10-31 20:07:58 EST
I did finally get the updated driver from Promise. And, as you, I
can't use the I2O driver in the updated kernel. I did manage to
compile their source driver, but it gave me some dependancy errors,
but I manually installed it, mkinitrd, and it has passed all the test
I've tried on it. I can tell you, after dealing with Promises (lack
of) tech support, this is the *last* product of theirs I buy...
Comment 3 Bugzilla owner 2004-09-30 11:41:25 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.