Bug 102142 - Can't drag-n-drop mail into composer window
Can't drag-n-drop mail into composer window
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: evolution (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-11 14:07 EDT by Stephen Harpster
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-11 14:11:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Harpster 2003-08-11 14:07:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030709

Description of problem:
Previous versions of evolution allowed you to use drag-n-drop to attach mail
messages to new messages in the composer window.  Now, however, you get a link
instead to 

file:///tmp/evolution-<number>/drag-n-drop-<string>/<subject>.  

If the receiver is on different host (which is most likely), they won't be able
to read the file referenced by this link.  (The link does not expand to the file
when you hit "Send".  To prove this, add yourself to the CC: line and send it. 
When you receive the message, you'll see the above link and not the contents
itself.)

Version-Release number of selected component (if applicable):
evolution-1.4.3-1

How reproducible:
Always

Steps to Reproduce:
1. Select "New" to open the composer window.
2. Select a mail message from Evolution.  It can be from the INBOX or
any other folder you may have.
3. Drag the mail message to the text entry field of the composer (left-click the
mouse on the Sender's name or subject field, drag the mouse to the composition
window, and release the button). 

Actual Results:  A link appears:

file:///tmp/evolution-<number>/drag-n-drop-<string>/<subject>

Expected Results:  An attachment should have been created that contained the
mail message.

Additional info:
Comment 1 Jeremy Katz 2003-08-11 14:11:34 EDT
You have to drag and drop onto the attach button in the toolbar (and there was a
really good reason for this, I just don't remember what it was at the moment --
it 's in the evolution list archives if you're interested in the reasoning)

Note You need to log in before you can comment on or make changes to this bug.