Bug 1021467 - Could not delete app after failed to create app on INT
Could not delete app after failed to create app on INT
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Abhishek Gupta
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-21 07:08 EDT by Wei Sun
Modified: 2015-05-14 20:22 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-23 22:25:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wei Sun 2013-10-21 07:08:10 EDT
Description of problem:
After failed to create app,try to delete this app,but could not delete app successfully.But run `rhc domain show`,this broken app is still listed.

Version-Release number of selected component (if applicable):
INT

How reproducible:
Always

Steps to Reproduce:
1.Create an application ,but failed
2.Run `rhc domain show`
3.Delete this broken app

Actual results:
1.rhc app create nds nodejs-0.6 mysql-5.1 mongodb-2.2 postgresql-8.4 -s --no-git --no-dns -g large --server int.openshift.redhat.com -l wsun+1@redhat.com
Application Options
-------------------
  Domain:     wsun1int
  Cartridges: nodejs-0.6, mysql-5.1, mongodb-2.2, postgresql-8.4
  Gear Size:  large
  Scaling:    yes

Creating application 'nds' ... exception: connect failed

2.openshift@openshift-ubuntu:~$ rhc domain show
Please sign in to start a new session to int.openshift.redhat.com.
Password: ******

Domain wsun1int (owned by wsun+1@redhat.com)
--------------------------------------------
  Created:            Oct 18 12:53 AM
  Allowed Gear Sizes: small, medium, large

 nds @ http://nds-wsun1int.int.rhcloud.com/ (uuid: 5264eda86cec0e38c6000262)
  ---------------------------------------------------------------------------
    Domain:     wsun1int
    Created:    5:02 AM
    Gears:      2 (defaults to large)
    Git URL:    ssh:///~/git/nds.git/
    SSH:        ssh://
    Deployment: manual (use 'rhc deploy')

3.openshift@openshift-ubuntu:~/test$ rhc delete-app nds -l wsun+1@redhat.com 
This is a non-reversible action! Your application code and data will be permanently deleted if you continue!

Are you sure you want to delete the application 'nds'? (yes|no): yes

Deleting application 'nds' ... 
Unable to complete the requested operation due to: undefined method `set_user_env_vars' for #<Gear:0x000000072bf500>.
Reference ID: c423d67ca3ec556ae712763a6acdb40d

Expected results:
Could delete this app successfully

Additional info:
Comment 1 Yan Du 2013-10-21 07:24:27 EDT
met the same problem on INT, can't delete app after failed to create app.
then the account is broken and always show the below error when creating app.


[root@localhost dataprepare]# rhc app delete cnodejs010salldbjkns84 --confirm -l yadu+m@redhat.com
Deleting application 'cnodejs010salldbjkns84' ... 
createuser: creation of new role failed: ERROR:  role "adminwh6a3sg" already exists
/var/lib/openshift/5264f51a03ef6404100000ae/postgresql/bin/post_install: line 13: error: command not found



[root@localhost dataprepare]# rhc app create phpsqlmyadmin php-5.3 mysql-5 phpmyadmin --no-git
Using mysql-5.1 (MySQL 5.1) for 'mysql-5'
Using phpmyadmin-4 (phpMyAdmin 4.0) for 'phpmyadmin'

Application Options
-------------------
  Domain:     aaa
  Cartridges: php-5.3, mysql-5.1, phpmyadmin-4
  Gear Size:  default
  Scaling:    no

Creating application 'phpsqlmyadmin' ... 
createuser: creation of new role failed: ERROR:  role "adminwh6a3sg" already exists
/var/lib/openshift/5264f51a03ef6404100000ae/postgresql/bin/post_install: line 13: error: command not found
Comment 2 Eric Christensen 2013-10-21 09:32:22 EDT
I, too, am seeing this problem although I suspect mine failed to build because I used an incorrect git repo.  I've got two applications that I cannot remove, though.
Comment 3 openshift-github-bot 2013-10-21 22:52:35 EDT
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/fcae2c3d7778d645758352fcdc6a006d95c29e96
Fix for bug 1020440, 1021041, 1021462, 1021467, and a typo
Comment 4 Abhishek Gupta 2013-10-22 13:05:23 EDT
Fixed with --> https://github.com/openshift/origin-server/pull/3939
Comment 6 Wei Sun 2013-10-23 05:53:41 EDT
Check this bug on STG(devenv-stage_528),could not reproduce this bug,could create and delete app successfully,and could delete app successfully after app failed to build.
Comment 7 Wei Sun 2013-10-23 05:56:00 EDT
Will verify this bug after checking on INT
Comment 8 Wei Sun 2013-10-23 06:57:36 EDT
Try to create an application with  incorrect download cartridge in STG(devenv-stage_528),when the creation failed,the app creating is rolled back successfully.
Comment 9 Wei Sun 2013-10-25 01:17:04 EDT
Checked broken app in INT(devenv_3942),the broken app is deleted.

Tried to create an application with  incorrect download cartridge,when the creation failed,the app creating is rolled back successfully.

So verify this bug.
Comment 10 Eric Christensen 2013-10-25 10:09:25 EDT
When the applications delete do you see your gears being released or are they still being shown as in use?  I'm using 4 gears but showing that 8 are being used after the broken apps were removed.
Comment 11 Wei Sun 2013-10-26 00:28:01 EDT
Check my account,after the broken app was removed,my gears were released.I'm using 10 gears,and showing that 10 gears are being used.

Note You need to log in before you can comment on or make changes to this bug.