Bug 1021472 - [origin_runtime_293] show Permission denied for performance.conf when deploy php/ruby/python app after migration
[origin_runtime_293] show Permission denied for performance.conf when deploy ...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Dan McPherson
libra bugs
:
: 1023256 1023901 1024304 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-21 07:25 EDT by Yan Du
Modified: 2015-05-14 19:30 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-23 22:25:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yan Du 2013-10-21 07:25:47 EDT
Description of problem:

show Permission denied for performance.conf when deploy php/ruby/python app after migration



Version-Release number of selected component (if applicable):
devenv_stage_518--->devenv_3921



How reproducible:
Always



Steps to Reproduce:

1. create an wordpress quickstart
2. upgrade
3. in local repo, make some change and git push



Actual results:

[root@Daphne wordpress]# git add .; git commit -am change3 ; git push
[master 43d81fd] change3
 Committer: root <root@Daphne.(none)>
 0 files changed, 0 insertions(+), 0 deletions(-)
 create mode 100644 aca
Counting objects: 3, done.
Delta compression using up to 8 threads.
Compressing objects: 100% (2/2), done.
Writing objects: 100% (2/2), 218 bytes, done.
Total 2 (delta 1), reused 0 (delta 0)
remote: Stopping PHP cartridge
remote: httpd (no pid file) not running
remote: Stopping MySQL cartridge
remote: Building git ref 'master', commit 43d81fd
remote: Building PHP cartridge
remote: Preparing build for deployment
remote: Prepared deployment artifacts in /var/lib/openshift/5264a0c8281d3266540000d0/app-deployments/2013-10-21_06-29-11.850
remote: Deployment id is cab836eb
remote: Activating deployment
remote: Starting MySQL cartridge
remote: 
remote: Database schema not yet added, WordPress is ready for install by visiting the site.
remote: Starting PHP cartridge
remote: /var/lib/openshift/5264a0c8281d3266540000d0/php/bin/control: line 13: /var/lib/openshift/5264a0c8281d3266540000d0/php//configuration/etc/conf.d/performance.conf: Permission denied
remote: Result: failure
remote: Activation status: failure
remote: Activation failed for the following gears:
remote: 5264a0c8281d3266540000d0 (Error activating gear: Failed to execute: 'control start' for /var/lib/openshift/5264a0c8281d3266540000d0/php)
remote: Deployment completed with status: failure
remote: postreceive failed
To ssh://5264a0c8281d3266540000d0@wordpress-dy.dev.rhcloud.com/~/git/wordpress.git/
   2c9ba79..43d81fd  master -> master


after deploy failed, app show 503 in web



Expected results:
app should deploy successfully without any error



Additional info:

1. ruby quickstart redmine deploy failed and show 503 in web too.

2. show "Permission denied" when deploy python django app, but the app can be deploy successfully and available in webpage.
Comment 1 Jhon Honce 2013-10-25 16:26:22 EDT
*** Bug 1023256 has been marked as a duplicate of this bug. ***
Comment 2 openshift-github-bot 2013-10-28 15:24:31 EDT
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/f5f4ce8b12d801d07d30a809b743b8ed0d6162d1
Bug 1021472: Correctly migrate cart dependency dirs
Comment 3 openshift-github-bot 2013-10-28 15:24:32 EDT
Commit pushed to master at https://github.com/openshift/li

https://github.com/openshift/li/commit/0f7d6e2fca11442b3aef359e8315d96832c1b417
Bug 1021472: Correctly migrate cart dependency dirs
Comment 5 openshift-github-bot 2013-10-28 19:59:29 EDT
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/17e075581479a3d0a2ab6860d4f8c1744887d16d
Bug 1021472: Mark php 0.0.7 upgrade incompatible

Ensure the performance.conf file is properly managed during upgrades by
marking the 0.0.7 version incompatible with prior versions.
Comment 6 Yan Du 2013-10-29 07:19:53 EDT
Test the app after migration from devenv_stage_528 to devenv_3959
Block by the #bug 1023345
Comment 7 Yan Du 2013-10-30 01:13:01 EDT
upgrade from devenv_stage_528 to devenv_3966

Test PHP/RUBY/PYTHON apps, php apps have fixed, but the "permission denied" issue still can be reproduced when deploy ruby and python apps. 


remote: Stopping Ruby cartridge
remote: httpd (no pid file) not running
remote: Building git ref 'master', commit 72cd68e
remote: Building Ruby cartridge
remote: Preparing build for deployment
remote: Deployment id is b129a64b
remote: Activating deployment
remote: Starting Ruby cartridge
remote: /var/lib/openshift/52707ed6d8e8a717940000f7/ruby/bin/control: line 15: /var/lib/openshift/52707ed6d8e8a717940000f7/ruby//etc/conf.d/performance.conf: Permission denied
remote: Result: failure
remote: Activation status: failure


remote: Starting PYTHON cart
remote: /var/lib/openshift/52707e9bd8e8a75e1f000001/python//usr/versions/2.6/bin/control: line 28: /var/lib/openshift/52707e9bd8e8a75e1f000001/python//etc/conf.d/performance.conf: Permission denied
remote: Result: success
remote: Activation status: success
remote: Deployment completed with status: success
To ssh://52707e9bd8e8a75e1f000001@django-dym.dev.rhcloud.com/~/git/django.git/
Comment 8 Dan McPherson 2013-10-30 11:33:15 EDT
We believe there isn't an issue that still exists for this bug.  We should do the following:

- Confirm that you are running oo-admin-upgrade with --ignore-cartridge-version
- Try against the latest devenv
- Try again with stage when those apps are updated.
Comment 9 Dan McPherson 2013-10-30 15:24:20 EDT
*** Bug 1024304 has been marked as a duplicate of this bug. ***
Comment 10 Dan McPherson 2013-10-30 16:05:38 EDT
*** Bug 1023901 has been marked as a duplicate of this bug. ***
Comment 12 Yan Du 2013-10-31 04:48:17 EDT
Steps

1. prepare apps on devenv_stage_528
2. upgrade to latest devenv (devenv_3973) with --ignore-cartridge-version
3. check the apps after migration

#bug 1021472: 

* Test OK for php/ruby/python old apps after migration.
* Test OK with php/ruby/python new app on devenv_3973
* Will test the app on stg after stg upgrade.

remote: HAProxy instance is started
remote: Starting Ruby cartridge
remote: Result: success
remote: Activation status: success
remote: Deployment completed with status: success
To ssh://5271fa786e177ce4ba000134@r18s-ydev.dev.rhcloud.com/~/git/r18s.git/
   b32724d..3a312d8  master -> master


remote: Starting PYTHON cart
remote: Result: success
remote: Activation status: success
remote: Deployment completed with status: success
To ssh://5271f8a96e177c2d9300010f@django-ydev.dev.rhcloud.com/~/git/django.git/
   8519d91..8ea089a  master -> master


#bug 1023901

Both ruby non-scalable and scalable app are available after migration

then move this bug to verified.

Note You need to log in before you can comment on or make changes to this bug.