Bug 1021484 - xmvn: installs malformed parent poms
xmvn: installs malformed parent poms
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xmvn (Show other bugs)
rawhide
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: Mikolaj Izdebski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-21 07:45 EDT by Mikolaj Izdebski
Modified: 2013-10-24 11:23 EDT (History)
6 users (show)

See Also:
Fixed In Version: 1.2.0-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-24 11:23:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikolaj Izdebski 2013-10-21 07:45:16 EDT
Description of problem:
Package maven fails to build from source in rawhide

Version-Release number of selected component (if applicable):
3.1.1-1

Actual results:
http://koji.fedoraproject.org/koji/taskinfo?taskID=6083413

Additional info:
This is caused by Sisu uopdate from M4 to M5. Maven builds fine after Sisu downgrade to M4.
Comment 1 Mikolaj Izdebski 2013-10-21 08:59:30 EDT
This even breaks Maven runtime so needs to be fixed ASAP.
Comment 2 Michal Srb 2013-10-22 01:14:25 EDT
The problem really seems to be somehow related to sisu. I have untagged sisu-0.0.0-0.6.M5.fc21 and Maven now builds fine:

http://koji.fedoraproject.org/koji/taskinfo?taskID=6085582

Note Maven now builds against sisu-0.0.0-0.5.M5, so update from M4 to M5 doesn't have to be the problem here. Keeping this bug open, since I still don't fully understand where the real problem lies.
Comment 3 Mikolaj Izdebski 2013-10-22 10:35:09 EDT
Moving to sisu.

This is causing more packages to fail to build, for example XMvn.
This is blocking an important XMvn bugfix so please resolve it ASAP.
Comment 4 Michal Srb 2013-10-23 03:31:49 EDT
I think I finally know where the problem is. Following lines from build.log are interesting:

[DEBUG] Artifact org.eclipse.sisu:sisu-plexus:pom:0.0.0.M5 was resolved to /usr/share/maven-poms/JPP-sisu-plexus.pom
[WARNING] The POM for org.eclipse.sisu:org.eclipse.sisu.plexus:jar:0.0.0.M5 is invalid, transitive dependencies (if any) will not be available: 1 problem was encountered while building the effective model for org.eclipse.sisu:org.eclipse.sisu.plexus:0.0.0.M5
[FATAL] Non-parseable POM /usr/share/maven-poms/JPP-sisu-plexus.pom: only whitespace content allowed before start tag and not P (position: START_DOCUMENT seen P... @1:1)  @ /usr/share/maven-poms/JPP-sisu-plexus.pom, line 1, column 1

And indeed, JPP-sisu-plexus.pom is malformed.

$ cat /usr/share/maven-poms/JPP-sisu-plexus.pom 
PKnRCMETA-INF/MANIFEST.MF??]??
? ?w?w??Z?"
???�8*O??hk?~&p?!'?`d??T??????;????aXM????5???????`m`??y[N,????P??&?c?PKnRC??&?c?META-INF/MANIFEST.MF??PKF?

$ file /usr/share/maven-poms/JPP-sisu-plexus.pom 
/usr/share/maven-poms/JPP-sisu-plexus.pom: Java Jar file data (zip)


My guess is that XMvn tries to inject artifact coordinates to POM only artifacts. If my assumption is correct, we will need to rebuild all the packages which contain parent pom and were built by XMvn 1.2.0.

From my rawhide machine:
$ file /usr/share/maven-poms/* | grep "Java Jar file" | wc -l
14

Reassigning to XMvn.
Comment 5 Mikolaj Izdebski 2013-10-23 05:02:02 EDT
Fixed in xmvn-1.2.0-2
Comment 6 Mikolaj Izdebski 2013-10-24 11:23:32 EDT
I believe that this bug is fixed in xmvn-1.2.0-4,
which is available in Fedora Rawhide, so I am closing this bug now.

The build containing the fix can be found at Koji:
http://koji.fedoraproject.org/koji/buildinfo?buildID=473166

Note You need to log in before you can comment on or make changes to this bug.