Bug 1021497 - [RHSC] - Status gives "No Rebalance ever happened on volume : <volName>"
[RHSC] - Status gives "No Rebalance ever happened on volume : <volName>"
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
medium Severity high
: ---
: RHGS 2.1.2
Assigned To: Kanagaraj
RamaKasturi
: Reopened, ZStream
Depends On: 1023921
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-21 08:07 EDT by RamaKasturi
Modified: 2016-04-18 06:06 EDT (History)
7 users (show)

See Also:
Fixed In Version: CB11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-25 02:41:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen shot (191.43 KB, image/png)
2013-12-13 08:31 EST, RamaKasturi
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 19598 None None None Never
Red Hat Product Errata RHEA-2014:0208 normal SHIPPED_LIVE Red Hat Storage 2.1 enhancement and bug fix update #2 2014-02-25 07:20:30 EST

  None (edit)
Description RamaKasturi 2013-10-21 08:07:47 EDT
Description of problem:
Status gives "No Rebalance ever happened on volume : <volName>"

Version-Release number of selected component (if applicable):
rhsc-2.1.2-0.0.scratch.beta1.el6_4.noarch

How reproducible:
Always

Steps to Reproduce:
1. Create a volume and start rebalance on the volume.
2. Once rebalance is completed, add a new server.
3. Now add a brick from the new server.

Actual results:
Now clicking on the status gives "No Rebalance ever happened on volume : <volName>"

Expected results:
Status should display the last rebalance status output.

Additional info:
Comment 2 RamaKasturi 2013-10-21 09:03:17 EDT
please find the link to sosreports:

http://rhsqe-repo.lab.eng.blr.redhat.com/sosreports/rhsc/1021497/
Comment 3 Dusmant 2013-10-24 02:22:40 EDT

*** This bug has been marked as a duplicate of bug 1021816 ***
Comment 4 Dusmant 2013-10-24 02:40:06 EDT
This bug is dependent on the Gluster FS issue. Though the end error is same, it's happening on a different operation flow and is consistent. 

This bug will be marked depends upon that glusterFS Bug.
Comment 5 RamaKasturi 2013-11-20 06:50:53 EST
This can be verified only when the BZ: 1023921
Comment 7 RamaKasturi 2013-12-13 08:29:34 EST
Verified in build cb11 rhsc-2.1.2-0.27.beta.el6_5.noarch.

When a brick is added from the new server, rebalance status shows the last rebalance run ouput.

Attaching the screenshot for the same.
Comment 8 RamaKasturi 2013-12-13 08:31:15 EST
Created attachment 836324 [details]
Screen shot
Comment 10 errata-xmlrpc 2014-02-25 02:41:54 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html

Note You need to log in before you can comment on or make changes to this bug.