Bug 1021532 - Wait with shortcuts creation probe until the server is fully booted
Wait with shortcuts creation probe until the server is fully booted
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Installer (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity medium
: ER7
: EAP 6.2.0
Assigned To: Francisco Canas
Petr Kremensky
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-21 09:13 EDT by Petr Kremensky
Modified: 2014-09-03 00:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:14:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Kremensky 2013-10-21 09:13:25 EDT
Description of problem:
 Installer is looking for server start code in separate thread, but server is said to be ready once installer find first of server started code. Installation process go on, but installer is keep printing "[ Server code detected: JBAS015874]" messages, because domain is yet booting. User can get confused as "Create shortcuts" message is lost between server start messages.

Version-Release number of selected component (if applicable):
 EAP 6.2.0.ER6

Steps to Reproduce:
 1. Start console installation: java -jar jboss-eap-6.2.0.ER6-installer.jar -console
 2. Select to start domain mode during installation
 3. Observe output while server is booting

Actual results:
[Host Controller] 15:01:18,799 INFO  [org.jboss.remoting] (MSC service thread 1-1) JBoss Remoting version 3.2.17.GA-redhat-1
Waiting for full server start:
.
.
[ Server code detected: JBAS015874]
[ Server code detected: JBAS015874]
Application Server successfully started.
Create shortcuts in the Start-Menu (y/n) [y]:[ Server code detected: JBAS015874]

Expected results:
[Host Controller] 15:01:18,799 INFO  [org.jboss.remoting] (MSC service thread 1-1) JBoss Remoting version 3.2.17.GA-redhat-1
Waiting for full server start:
.
.
[ Server code detected: JBAS015874]
[ Server code detected: JBAS015874]
[ Server code detected: JBAS015874]
Application Server successfully started.
Create shortcuts in the Start-Menu (y/n) [y]:
Comment 1 Francisco Canas 2013-10-21 12:01:00 EDT
I've adjusted how the GUI and console output works when starting the server:
- The server code detected string will only be shown once.
- No further server thread output to user once server is ready.
This way we will no longer have the possibility of writing server-start output to console when the installation has already advanced past the post-install stage.

See commit for details:
http://git.app.eng.bos.redhat.com/jbossas-installer.git/commit/?h=eap-6.2
Comment 2 Petr Kremensky 2013-11-01 08:41:19 EDT
Verified on EAP 6.2.0.ER7 installer.

Note You need to log in before you can comment on or make changes to this bug.