Bug 1021562 - Logging issue when running a standalone server with the full HA profile
Logging issue when running a standalone server with the full HA profile
Status: CLOSED NOTABUG
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Logging (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: James Perkins
Nikoleta Ziakova
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-21 10:10 EDT by sgilda
Modified: 2014-03-05 12:40 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-05 12:40:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sgilda 2013-10-21 10:10:57 EDT
Description of problem:

I discovered this issue while testing the hornetq-clustering quickstart in standalone mode. 

With both the ER5 and ER6 release, the first time I start server with the full HA profile, I see 6 'INFO' messages in the terminal where I start the server, the last telling me the JBoss Remoting version. On subsequent restarts, I do NOT see any 'INFO' messages telling me the server has started and is ready. 


*** This is what I see the first time I start the server:

$ bin/standalone.sh -c standalone-full-ha.xml

=========================================================================

  JBoss Bootstrap Environment

  JBOSS_HOME: /home/sgilda/tools/jboss-eap-6.2-ER6

  JAVA: /home/sgilda/JDKs/jdk1.7.0_09/bin/java

  JAVA_OPTS:  -server -XX:+UseCompressedOops -Xms1303m -Xmx1303m -XX:MaxPermSize=256m -Djava.net.preferIPv4Stack=true -Djboss.modules.system.pkgs=org.jboss.byteman -Djava.awt.headless=true

=========================================================================

08:36:34,156 INFO  [org.jboss.modules] (main) JBoss Modules version 1.3.0.Final-redhat-2
08:36:34,551 INFO  [org.jboss.msc] (main) JBoss MSC version 1.0.4.GA-redhat-1
08:36:34,642 INFO  [org.jboss.as] (MSC service thread 1-8) JBAS015899: JBoss EAP 6.2.0.GA (AS 7.3.0.Final-redhat-9) starting
08:36:36,246 INFO  [org.xnio] (MSC service thread 1-4) XNIO Version 3.0.7.GA-redhat-1
08:36:36,249 INFO  [org.jboss.as.server] (Controller Boot Thread) JBAS015888: Creating http management service using socket-binding (management-http)
08:36:36,253 INFO  [org.xnio.nio] (MSC service thread 1-4) XNIO NIO Implementation Version 3.0.7.GA-redhat-1
08:36:36,290 INFO  [org.jboss.remoting] (MSC service thread 1-4) JBoss Remoting version 3.2.17.GA-redhat-1


*** When I kill the server and restart it, this is all I see:

$ bin/standalone.sh -c standalone-full-ha.xml
=========================================================================

  JBoss Bootstrap Environment

  JBOSS_HOME: /home/sgilda/tools/jboss-eap-6.2-ER6

  JAVA: /home/sgilda/JDKs/jdk1.7.0_09/bin/java

  JAVA_OPTS:  -server -XX:+UseCompressedOops -Xms1303m -Xmx1303m -XX:MaxPermSize=256m -Djava.net.preferIPv4Stack=true -Djboss.modules.system.pkgs=org.jboss.byteman -Djava.awt.headless=true

=========================================================================



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 James Perkins 2013-10-21 11:38:25 EDT
The standalone-full-ha.xml does not include a console-handler for EAP 6. On the first boot the logging.properties does indeed include a console-handler which is why, but the standalone-full-ha.xml does not. The console-handler gets deleted after the logging subsystem is initialized which then writes the logging.properties. This is the expected behavior.
Comment 2 James Perkins 2014-03-05 12:40:10 EST
Closing as not a bug since this is by design. Console logging is disabled by default in standalone-full-ha. On the first boot this will log to the console since the logging.properties does contain a console handler. After that the logging.properties will be overwritten and will no longer log to the console.

Note You need to log in before you can comment on or make changes to this bug.