Bug 1021576 - Username indicated as "sign in" post redhat portal identification.
Username indicated as "sign in" post redhat portal identification.
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: redhat-access-plugin-openstack (Show other bugs)
4.0
Unspecified Linux
unspecified Severity medium
: beta
: 4.0
Assigned To: Dan Varga
Nir Magnezi
:
Depends On:
Blocks: 1019871 1022210
  Show dependency treegraph
 
Reported: 2013-10-21 10:38 EDT by Nir Magnezi
Modified: 2014-04-09 03:59 EDT (History)
6 users (show)

See Also:
Fixed In Version: redhat-access-plugin-openstack-4.0.0-0
Doc Type: Bug Fix
Doc Text:
A bug in Strata (the Customer Portal API) sometimes sends invalid responses to the Red Hat Access user interface. Whenever this occurred, Red Hat Access incorrectly prompted users to log in even when they were already logged in. With this fix, the Red Hat Access plugin now completely disables the "Search" and "Diagnose" fields unless the user is correctly logged in. In addition, Red Hat Access tests user login status each time the browser window is in focus (instead of during page refreshes). These measures prevent users from receiving incorrect login prompts whenever Strata sends an invalid response.
Story Points: ---
Clone Of:
: 1022210 (view as bug list)
Environment:
Last Closed: 2013-12-19 19:30:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nir Magnezi 2013-10-21 10:38:13 EDT
Description of problem:
=======================
At the redhat access UI, The indication that the user is already signed in to the redhat customer portal does not always work.
I see: Please sign in to the Red Hat Customer Portal to access this information. Sign In
dispite the fact that I'm logged in the redhat customer portal.
refreshing the page did not help to fix this.

Version-Release number of selected component (if applicable):
=============================================================
Puddle 2013-10-15.1
redhat-access-plugin-openstack-1.2.0-5.el6ost.noarch

How reproducible:
=================
3/3
It worked ok from time to time, but did not work in most cases that I've tried.

Steps to Reproduce:
===================
1. Install OpenStack via packstack.
2. Browse to the redhat access tab.
3. Click sign in.
4. Enter your credentials and login to the redhat customer portal
5. Go back to the redhat access tab.
6. Refresh the page.

Actual results:
===============
"Please sign in to the Red Hat Customer Portal to access this information. Sign In"

Expected results:
=================
Indication that the user is already logged in (with the user name displayed).
Comment 2 Dan Varga 2013-10-21 10:53:40 EDT
Hi Nir,

I'm also seeing this behavior with the actual customer portal currently as well.  I'm thinking this is a problem with the portal and not necessarily the plugin.

I can see in the cookie payload that the cookie is there, but the JSON callback response is incorrect:

jQuery171032164081605151296_1382366619110({
	authorized: false,
	internal: false,
	login:"",
	user_id:"",
	account_id:"",
	account_number:"",
	lang:"en",
	lang_err_msg:"The page you have selected is not yet available in English. We are working to make sure all content is available in English, but in order to display the page we have switched your language to English.",
	hello:"Hello,",
	description_placeholder:"Enter a description",
	name:" "
})

Checking with the portal team on this now.  The plugin is doing the appropriate thing given the data it has received.
Comment 3 Nir Magnezi 2013-10-22 02:25:04 EDT
Hi Dan,

Thank you for the this input.
waiting for updates about this.
Comment 4 Dan Varga 2013-10-22 11:47:29 EDT
Hi Nir,

I've found a few parts of the code that could be improved to better handle the situation where Strata does not return a good response.  Still investigating with them on the root issue though.

I have the updated code ready and will kick off a brew build once all the ACKs are in place.
Comment 6 Nir Magnezi 2013-11-04 09:21:47 EST
Verified NVR: redhat-access-plugin-openstack-4.0.0-0.el6ost.noarch

Dan Wrote:

Hi Nir,

I've made it so the search box + button are 'disabled' if the user is not logged in to the customer portal.  I have also removed the requirement of refreshing the page to determine if the user is logged in.  Each time the browser window gets the 'focus' event, the user's status is tested.


I've tested this and it works exactly as described.
Comment 8 errata-xmlrpc 2013-12-19 19:30:17 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.