Bug 1021618 - resolution set by user inside the VM gets reverted to client resolution when in full screen
resolution set by user inside the VM gets reverted to client resolution when ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: mingw-virt-viewer (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity medium
: ---
: 3.3.0
Assigned To: Jonathon Jongsma
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-21 12:07 EDT by David Jaša
Modified: 2014-01-21 09:47 EST (History)
6 users (show)

See Also:
Fixed In Version: mingw-virt-viewer-0.5.6-12
Doc Type: Bug Fix
Doc Text:
Previously when a user set a window in fullscreen and then changed the resolution in the guest, the guest resolution reverted to the resolution of the client. Fullscreen windows now allow user to set the resolution of the guest to a resolution higher than the native client resolution.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 09:47:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Jaša 2013-10-21 12:07:19 EDT
Description of problem:
resolution set by user inside the VM gets reverted to client resolution when in full screen. This is essentially a regression of bug 864929 (and clones) that is in 3.3 client (but not in 6.5 client). The regression occurs always when "auto resize" is enabled with the only exception when the client is launched with --full-screen=auto-conf and the client is not subsequently unmaximized.

The current behaviour of windows client is bad IMO because it overrides explicit user action no no really good reason (when users want to revert to client resolution, they are able to do that through window/fulscreen cycle or in ideal world, with ctrl+0 shortcut)

Version-Release number of selected component (if applicable):
mingw-virt-viewer-0.5.6-6

How reproducible:
always

Steps to Reproduce:
1. connect to a guest with agent, go to full-screen
2. in the guest, change resolution to something else
3.

Actual results:
resolution gets reverted right away

Expected results:
resolution is left as-is (as in RHEL 6.5 client or when connected with --full-screen=auto-conf)

Additional info:
Comment 4 Jonathon Jongsma 2013-11-11 14:23:21 EST
added patches from Bug #864929
Comment 7 Charlie 2013-11-27 20:25:53 EST
This bug is currently attached to errata RHEA-2013:15512. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 9 errata-xmlrpc 2014-01-21 09:47:27 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0034.html

Note You need to log in before you can comment on or make changes to this bug.